compat-wireless: fix patches/44-deactivate-mac80211-tracing.patch
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 10 Feb 2012 20:45:13 +0000 (12:45 -0800)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 10 Feb 2012 20:45:13 +0000 (12:45 -0800)
Tracing stuff is now compiled-in if tracing is enabled in your
build, but we keep it disabled regardless for compat.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
patches/44-deactivate-mac80211-tracing.patch

index feff5eb9a00975e2c9df4100c83d4b74abb4e913..6445f30c217be73f7c562caceef092f777ac18ec 100644 (file)
@@ -4,41 +4,12 @@ include/trace/events/module.h which makes this not compiling any more.
 
 --- a/net/mac80211/Makefile
 +++ b/net/mac80211/Makefile
-@@ -24,8 +24,7 @@ mac80211-y := \
-       util.o \
+@@ -25,7 +25,7 @@ mac80211-y := \
        wme.o \
        event.o \
--      chan.o \
--      driver-trace.o
-+      chan.o
+       chan.o \
+-      driver-trace.o mlme.o
++      mlme.o
  
  mac80211-$(CONFIG_MAC80211_LEDS) += led.o
  mac80211-$(CONFIG_MAC80211_DEBUGFS) += \
-@@ -42,6 +41,7 @@ mac80211-$(CONFIG_MAC80211_MESH) += \
- mac80211-$(CONFIG_PM) += pm.o
-+mac80211-$(CONFIG_MAC80211_DRIVER_API_TRACER) += driver-trace.o
- CFLAGS_driver-trace.o := -I$(src)
- # objects for PID algorithm
---- a/net/mac80211/driver-trace.h
-+++ b/net/mac80211/driver-trace.h
-@@ -5,6 +5,17 @@
- #include <net/mac80211.h>
- #include "ieee80211_i.h"
-+#if !defined(CONFIG_MAC80211_DRIVER_API_TRACER) || defined(__CHECKER__)
-+#undef TRACE_EVENT
-+#define TRACE_EVENT(name, proto, ...) \
-+static inline void trace_ ## name(proto) {}
-+#undef DECLARE_EVENT_CLASS
-+#define DECLARE_EVENT_CLASS(...)
-+#undef DEFINE_EVENT
-+#define DEFINE_EVENT(evt_class, name, proto, ...) \
-+static inline void trace_ ## name(proto) {}
-+#endif
-+
- #undef TRACE_SYSTEM
- #define TRACE_SYSTEM mac80211