projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ebaa381
)
kernel: add usb3 module definitions
author
John Crispin
<john@openwrt.org>
Sun, 19 Jan 2014 17:27:40 +0000
(17:27 +0000)
committer
John Crispin
<john@openwrt.org>
Sun, 19 Jan 2014 17:27:40 +0000
(17:27 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 39331
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 5d26190eb30e4f9a6b9126dbb1fd301f33733cac..825b29e3cb5b957b155da144bb26a263666d6400 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-1132,3
+1132,21
@@
define KernelPackage/usbmon/description
endef
$(eval $(call KernelPackage,usbmon))
+
+
+define KernelPackage/usb3
+ TITLE:=Support for USB3 controllers
+ KCONFIG:= \
+ CONFIG_USB_XHCI_HCD \
+ CONFIG_USB_XHCI_HCD_DEBUGGING=n
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
+ AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb3/description
+ Kernel support for USB3 (XHCI) controllers
+endef
+
+$(eval $(call KernelPackage,usb3))