projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8a0d981
)
build: undefine debug helper templates used by subdir.mk if the DEBUG variable is...
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Apr 2011 03:40:01 +0000
(
03:40
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Apr 2011 03:40:01 +0000
(
03:40
+0000)
SVN-Revision: 26434
include/debug.mk
patch
|
blob
|
history
diff --git
a/include/debug.mk
b/include/debug.mk
index faead042dc4a81909cef3689b94f9a11b367ad74..bec74d187a4fd44e50c10932f5706fdb4ff0a663 100644
(file)
--- a/
include/debug.mk
+++ b/
include/debug.mk
@@
-21,6
+21,8
@@
ifeq ($(DUMP),)
endif
endif
+ifneq ($(DEBUG),)
+
define debug
$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
endef
@@
-38,4
+40,12
@@
$(call warn,$(1),$(2),$(3) $(4))
$(4)
endef
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif