Annotate what we need for ar9170 for older kernels
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 15 Jul 2009 22:25:44 +0000 (15:25 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 15 Jul 2009 22:25:44 +0000 (15:25 -0700)
To get ar9170 working on 2.6.27 we need to backport:

* usb_get_from_anchor()
* usb_poison_anchored_urbs()
* usb_unpoison_anchored_urbs()

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk

index aa1a3fe000e917e1f4acaad053ec57ab12c737ca..0dc2fe9ff8b08723bf1ca522901e3c89433fe76d 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -274,7 +274,10 @@ CONFIG_RTL8187=m
 CONFIG_AT76C50X_USB=m
 
 # Activate AR9170 support only on kernel >= 2.6.29.
-# The needed USB poison feature was added in this kernel release.
+# You need to backport:
+# * usb_get_from_anchor()
+# * usb_poison_anchored_urbs()
+# * usb_unpoison_anchored_urbs()
 ifeq ($(shell test $(KERNEL_SUBLEVEL) -ge 29 && echo yes),yes)
 CONFIG_AR9170_USB=m
 CONFIG_AR9170_LEDS=y