projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8ed5701
)
base-files: only relink libraries if the linaro toolchain is selected
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 9 Mar 2011 20:36:29 +0000
(20:36 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 9 Mar 2011 20:36:29 +0000
(20:36 +0000)
SVN-Revision: 25983
package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index 086dd32bd8b4146fe367f8a680eef0fab4d638e5..bf8d30d7b721ada5d3eb828d8880f1789864e3ae 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-328,7
+328,9
@@
LIBGCC_A=$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc_pic.a)
LIBGCC_MAP=$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.map)
LIBGCC_SO=$(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so.*)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
- BUILD_LIBGCC:=$(if $(CONFIG_avr32)$(CONFIG_m68k)$(CONFIG_powerpc),,$(PKG_BUILD_DIR)/libgcc_s.so.*)
+ ifneq ($(CONFIG_GCC_VERSION_LINARO),)
+ BUILD_LIBGCC:=$(if $(CONFIG_avr32)$(CONFIG_m68k)$(CONFIG_powerpc),,$(PKG_BUILD_DIR)/libgcc_s.so.*)
+ endif
endif
ifneq ($(BUILD_LIBGCC),)