compat-wireless: modules declared as PHONY target in Makefile
authorBala Shanmugam <sbalashanmugam@atheros.com>
Thu, 17 Dec 2009 12:42:25 +0000 (18:12 +0530)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 19 Dec 2009 01:15:39 +0000 (17:15 -0800)
When a particular file alone is modified in compat package, it is not compiled with make.
To compile the modified file compat package needs to be cleaned up and all files need to be compiled.
This is because all files are compiled in modules target, and file by name modules is not generated.
So this target will be considered up-to-date once compiled.

modules target is declared as PHONY target to avoid this problem.

I feel config.mk need not be included when KERNELRELEASE is not NULL as
it degrades the performance and doesn't make any difference.  Please comment.

Signed-off-by: Bala Shanmugam <sbalashanmugam@atheros.com>
Makefile

index ddaa656523419e7af14d0fb4a2ad4784bf917df3..d19720291985dd53bb1a0825f70cbfdb6eb58673 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,8 +15,6 @@ DESTDIR?=
 
 ifneq ($(KERNELRELEASE),)
 
-include $(M)/$(COMPAT_CONFIG)
-
 NOSTDINC_FLAGS := -I$(M)/include/ -include $(M)/include/linux/compat-2.6.h $(CFLAGS)
 
 obj-y := compat/
@@ -295,7 +293,7 @@ wlunload:
 wlload: wlunload
        @./scripts/wlload.sh
 
-.PHONY: all clean install uninstall unload load btunload btload wlunload wlload
+.PHONY: all clean install uninstall unload load btunload btload wlunload wlload modules
 
 endif