add libmodbus
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 22:03:25 +0000 (22:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 22:03:25 +0000 (22:03 +0000)
Apparently people are already using libmodbus on OpenWrt, but there is no package.
(see http://zagrodzki.net/~sebek/openwrt/packages/libmodbus.so )
So I made a Makefile for it, I'd be happy to be the package maintainer for that.

SVN-Revision: 26345

libs/libmodbus/Makefile [new file with mode: 0644]

diff --git a/libs/libmodbus/Makefile b/libs/libmodbus/Makefile
new file mode 100644 (file)
index 0000000..e379ad8
--- /dev/null
@@ -0,0 +1,50 @@
+# 
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libmodbus
+PKG_VERSION:=2.0.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://github.com/downloads/stephane/libmodbus/
+PKG_MD5SUM:=0646f3edca6d7783d0356dc2fc4f9f4c
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libmodbus
+  SECTION:=libs
+  CATEGORY:=Libraries
+  URL:=http://www.libmodbus.org
+  TITLE:=libmodbus
+endef
+
+define Package/libmodbus/description
+A Modbus library for Linux, Mac OS X, FreeBSD, QNX and Win32 
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/modbus $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmodbus.{so*,la} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/modbus.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libmodbus/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmodbus.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libmodbus))