mac80211: mark ath12k 80211BE capable
authorJanusz Dziedzic <janusz.dziedzic@gmail.com>
Mon, 23 Sep 2024 06:26:08 +0000 (08:26 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 3 Oct 2024 10:55:23 +0000 (12:55 +0200)
Build hostapd with 80211BE suport.

Signed-off-by: Janusz Dziedzic <janusz.dziedzic@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16571
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/mac80211/ath.mk

index eecaef4588871ee56eff737d2c5d9ba1c40a5d5a..5b13b6aac4ad99e20b1d2cb92a01bdc78c9fda33 100644 (file)
@@ -362,7 +362,7 @@ define KernelPackage/ath12k
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath12k
   DEPENDS+= @PCI_SUPPORT +kmod-ath +@DRIVER_11AC_SUPPORT +@DRIVER_11AX_SUPPORT \
   +kmod-crypto-michael-mic +kmod-qrtr-mhi \
-  +kmod-qcom-qmi-helpers
+  +kmod-qcom-qmi-helpers +@DRIVER_11BE_SUPPORT
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath12k/ath12k.ko
   AUTOLOAD:=$(call AutoProbe,ath12k)
 endef