#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=gkrellmd
-PKG_VERSION:=2.2.10
+PKG_VERSION:=2.3.1
PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://members.dslextreme.com/users/billw/gkrellm/
PKG_SOURCE:=gkrellm-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=57ef0525c0997ac2e7720712811f5a84
+PKG_SOURCE_URL:=http://members.dslextreme.com/users/billw/gkrellm/
+PKG_MD5SUM:=009d8dddd3ce5cc83a4bb4d559ee922d
PKG_BUILD_DIR:=$(BUILD_DIR)/gkrellm-$(PKG_VERSION)
SECTION:=admin
CATEGORY:=Administration
DEPENDS:=+glib1
- TITLE:=System monitoring daemon
+ TITLE:=The GNU Krell Monitors Server
URL:=http://gkrellm.net/
endef
+define Package/gkrellmd/description
+ Gkrellmd Listens for connections from gkrellm clients. When
+ a gkrellm client connects to a gkrellmd server all builtin
+ monitors collect their data from the server.
+endef
+
define Build/Compile
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CPPFLAGS)" \
LDFLAGS="$(EXTRA_LDFLAGS) " \
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_BUILD_DIR)/server/$(PKG_NAME).conf $(1)/etc/
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/gkrellmd.init $(1)/etc/init.d/gkrellmd
+ $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
endef
$(eval $(call BuildPackage,gkrellmd))
-diff -ur gkrellm-2.2.10~/server/gkrellmd.conf gkrellm-2.2.10/server/gkrellmd.conf
---- gkrellm-2.2.10~/server/gkrellmd.conf 2005-05-22 11:56:53.000000000 -0400
-+++ gkrellm-2.2.10/server/gkrellmd.conf 2007-03-10 23:32:23.000000000 -0500
+Index: gkrellm-2.3.1/server/gkrellmd.conf
+===================================================================
+--- gkrellm-2.3.1.orig/server/gkrellmd.conf 2008-03-09 10:19:26.000000000 +0100
++++ gkrellm-2.3.1/server/gkrellmd.conf 2008-03-09 10:19:26.000000000 +0100
@@ -4,7 +4,7 @@
# the client update frequency. Values may be from 1 to 10 and should be
# smaller values to reduce network traffic.
# Limit number of simultaneous clients allowed to connect.
#
-@@ -17,18 +17,18 @@
- # List of hosts allowed to connect. If no hosts are specified in a
- # gkrellmd.conf file or on the command line, all hosts will be allowed.
+@@ -13,7 +13,7 @@
+ # Specify a specific network interface to listen on for connections.
+ # By default gkrellmd listens on all available network interfaces.
#
--#allow-host localhost
-+allow-host localhost
- #allow-host 127.0.0.1
- #allow-host ::1
- #allow-host 192.168.0.*
+-address 127.0.0.1
++#address 127.0.0.1
+
+ # Specify the port to listen on for connections.
+ #
+@@ -29,14 +29,14 @@
# Drop privileges after startup (you must start gkrellmd as root to do it).
#
+user nobody
#group proc
+ # Create a PID file for the running gkrellmd. Default is no PID file.
+-#pidfile /var/run/gkrellmd.pid
++pidfile /var/run/gkrellmd.pid
+
# Run in background and detach from the controlling terminal
-#detach
+detach