[package] add dnsmax and thatip provides to ddns-scripts (#6416)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 12:14:12 +0000 (12:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 2 Jan 2010 12:14:12 +0000 (12:14 +0000)
SVN-Revision: 18992

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/services

index 444e931173a96a9b0b86be70518016b35b4787f8..53cb961f10a422c083d7e75d3ccaab13c450cb1c 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 7fafba15781ec64bfcb5f922df0e48b8e858aa44..8105a0f5ccead0b3d9bdfe2746dca01220775158 100644 (file)
@@ -13,7 +13,7 @@
 "zoneedit.com"         "http://[USERNAME]:[PASSWORD]@dynamic.zoneedit.com/auth/dynamic.html?host=[DOMAIN]&dnsto=[IP]"
 
 #noip is an alias of no-ip, so allow both names for the same service
-"no-ip.com"            "http://dynupdate.no-ip.com/ducupdate.php?username=[USERNAME]&pass=[PASSWORD]&h[]=[DOMAIN]&ip=[IP]"     
+"no-ip.com"            "http://dynupdate.no-ip.com/ducupdate.php?username=[USERNAME]&pass=[PASSWORD]&h[]=[DOMAIN]&ip=[IP]"
 "noip.com"             "http://dynupdate.no-ip.com/ducupdate.php?username=[USERNAME]&pass=[PASSWORD]&h[]=[DOMAIN]&ip=[IP]"
 
 #freedns.afraid.org is weird, you just need an update code, for which we use the password variable
@@ -27,3 +27,7 @@
 # If anyone has time they could update this file to be compatible with a bunch of them                    #
 #                                                                                                         #
 ###########################################################################################################
+
+# DNS Max and resellers' update urls
+"dnsmax.com" "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=1&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"
+"thatip.com" "http://update.dnsmax.com/update/?username=[USERNAME]&password=[PASSWORD]&resellerid=2&clientname=openwrt&clientversion=8.09&protocolversion=2.0&updatehostname=[DOMAIN]&ip=[IP]"