qoriq: add support for WatchGuard Firebox M200
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 6 Dec 2021 10:45:12 +0000 (12:45 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 8 Feb 2023 15:18:05 +0000 (17:18 +0200)
Boots, no network.

setenv OpenWrt_kernel watchguard_firebox-m200-fit-uImage.itb
setenv loadaddr 0x20000000
setenv wgBootSysA 'setenv bootargs root=/dev/mmcblk0p2 rw rootdelay=2 console=$consoledev,$baudrate fsl_dpaa_fman.fsl_fm_max_frm=1536; mmc dev 0; ext2load mmc 0:1 $loadaddr $OpenWrt_kernel; bootm $loadaddr'
saveenv
reset

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m200.dts [new file with mode: 0644]
target/linux/qoriq/image/generic.mk

diff --git a/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m200.dts b/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m200.dts
new file mode 100644 (file)
index 0000000..1759360
--- /dev/null
@@ -0,0 +1,55 @@
+/*
+ * T1042RDB_PI Device Tree Source
+ *
+ * Copyright 2014 - 2015 Freescale Semiconductor Inc.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *     * Redistributions of source code must retain the above copyright
+ *      notice, this list of conditions and the following disclaimer.
+ *     * Redistributions in binary form must reproduce the above copyright
+ *      notice, this list of conditions and the following disclaimer in the
+ *      documentation and/or other materials provided with the distribution.
+ *     * Neither the name of Freescale Semiconductor nor the
+ *      names of its contributors may be used to endorse or promote products
+ *      derived from this software without specific prior written permission.
+ *
+ *
+ * ALTERNATIVELY, this software may be distributed under the terms of the
+ * GNU General Public License ("GPL") as published by the Free Software
+ * Foundation, either version 2 of that License or (at your option) any
+ * later version.
+ *
+ * THIS SOFTWARE IS PROVIDED BY Freescale Semiconductor "AS IS" AND ANY
+ * EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ * DISCLAIMED. IN NO EVENT SHALL Freescale Semiconductor BE LIABLE FOR ANY
+ * DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+ * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+ * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+ * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+/include/ "t104xsi-pre.dtsi"
+/include/ "t104xrdb.dtsi"
+
+/ {
+       model = "WatchGuard Firebox M200";
+       compatible = "watchguard,firebox-m200", "fsl,T1042RDB_PI";
+
+};
+
+#include "t1040si-post.dtsi"
+#include "watchguard-firebox-mx00-ifc.dtsi"
+
+/ {
+
+       localbus@ffe124000 {
+               /* one of these causes serious havoc, didn't happen in m200 branch */
+               /* likely due to qoriq having more kernel options enabled, disable for now */
+               /delete-node/ nor@0,0;
+               /delete-node/ nand@2,0;
+       };
+};
index d2b60d22962f666a54c73022fdb45c223a9ce086..01f198ceeee9fe712f9f45d4b3cfe6c384bbe755 100644 (file)
@@ -1,3 +1,18 @@
+define Device/watchguard_firebox-m200
+  DEVICE_VENDOR := WatchGuard
+  DEVICE_MODEL := Firebox M200
+  DEVICE_DTS_DIR := $(DTS_DIR)/fsl
+  DEVICE_PACKAGES := \
+       kmod-hwmon-w83793 kmod-ptp-qoriq kmod-rtc-rs5c372a kmod-tpm-i2c-atmel
+  KERNEL := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+  KERNEL_SUFFIX := -fit-uImage.itb
+  IMAGES := sdcard.img.gz sysupgrade.img.gz
+  IMAGE/sysupgrade.img.gz :=  sdcard-img | gzip | append-metadata
+  IMAGE/sdcard.img.gz := sdcard-img | gzip
+endef
+
+TARGET_DEVICES += watchguard_firebox-m200
+
 define Device/watchguard_firebox-m300
   DEVICE_VENDOR := WatchGuard
   DEVICE_MODEL := Firebox M300