musl-fts: remove shared libraries from host
authorRosen Penev <rosenp@gmail.com>
Fri, 24 Sep 2021 06:44:57 +0000 (23:44 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 4 Apr 2022 22:20:24 +0000 (00:20 +0200)
Avoids having to add rpath to the various packages using it. Also add
PIC to fix compilation as static libraries do not use PIC by default.

Fixes: 1fb099341e58 ("musl-fts: add host build")
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf)

package/libs/musl-fts/Makefile

index 494f700f8a651b552d3ff28438da2dc93f6261cc..9f4bdf12a3d9a186039c631752ad47c1e9cdda01 100644 (file)
@@ -43,6 +43,7 @@ define Package/musl-fts/description
   The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc.
 endef
 
+HOST_CONFIGURE_ARGS += --disable-shared --with-pic
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include