Update httping to 1.2.6 (#3624)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 14:16:21 +0000 (14:16 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 Jul 2008 14:16:21 +0000 (14:16 +0000)
SVN-Revision: 11707

net/httping/Makefile
net/httping/patches/001-extra_flags.patch
net/httping/patches/002-version.patch

index 715346ffbfbc98fc47afbb603e4f181d2bf2302c..2b757e7d89f26e7ca0472d49c14be10fef385de2 100644 (file)
@@ -9,14 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.2.2
+PKG_VERSION:=1.2.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=2fa68b95d190a9e101232792df49e1ad
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,8 +27,8 @@ define Package/httping
 endef
 
 define Package/httping/description
-       Give it an url, and it'll show you how long it takes to connect, send a 
-       request and retrieve the reply (only the headers). Be aware that the 
+       Give it an url, and it'll show you how long it takes to connect, send a
+       request and retrieve the reply (only the headers). Be aware that the
        transmission across the network also takes time!
 endef
 
index 86c75e743e3a9b2c079c4ede0ed225135d748bbe..6d30ce35a36ac7341e5b0c857855af25ea635594 100644 (file)
@@ -1,6 +1,5 @@
-diff -ruaN httping-1.2.2.orig/Makefile httping-1.2.2/Makefile
---- httping-1.2.2.orig/Makefile        2006-11-09 20:13:12.000000000 +0100
-+++ httping-1.2.2/Makefile     2007-02-27 11:34:47.000000000 +0100
+--- a/Makefile
++++ b/Makefile
 @@ -15,8 +15,8 @@
  include version
  
index a0589f1c2406d4c1d54e1a54867467bd4ce0c4b3..11361ec4e10119f1844a7b40a5e002bfd0f4319b 100644 (file)
@@ -1,11 +1,10 @@
-diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c
---- httping-1.2.2.orig/main.c  2006-11-09 20:13:12.000000000 +0100
-+++ httping-1.2.2/main.c       2007-02-27 11:38:14.000000000 +0100
+--- a/main.c
++++ b/main.c
 @@ -40,6 +40,8 @@
  #include "utils.h"
  #include "error.h"
  
-+#define VERSION "1.2.2"
++#define VERSION "1.2.6"
 +
  static volatile int stop = 0;
  
@@ -14,12 +13,12 @@ diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c
  
  void version(void)
  {
--      fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2005 folkert@vanheusden.com\n");
-+      fprintf(stderr, "HTTPing v%s (C) 2003-2005 folkert@vanheusden.com\n", VERSION);
+-      fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2008 folkert@vanheusden.com\n");
++      fprintf(stderr, "HTTPing v%s (C) 2003-2008 folkert@vanheusden.com\n", VERSION);
  #ifndef NO_SSL
        fprintf(stderr, "SSL support included\n");
  #endif
-@@ -413,7 +415,7 @@
+@@ -425,7 +427,7 @@
        if (useragent)
                sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
        else