toolchain: gcc: update GCC 14 to 14.2.0
authorThomas Weißschuh <thomas@t-8ch.de>
Thu, 1 Aug 2024 15:59:42 +0000 (17:59 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 12 Aug 2024 22:30:29 +0000 (00:30 +0200)
All patches automatically rebased.

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
Link: https://github.com/openwrt/openwrt/pull/16047
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/gcc/Config.version
toolchain/gcc/common.mk
toolchain/gcc/patches-14.x/300-mips_Os_cpu_rtx_cost_model.patch

index dc2ff9bff037cd7a3dd8573405c2f011b8c8c183..49bb36865eebb9d885cb97bddfbc84dcceb4705a 100644 (file)
@@ -15,7 +15,7 @@ config GCC_VERSION
        default EXTERNAL_GCC_VERSION    if EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
        default "11.3.0"        if GCC_VERSION_11
        default "12.3.0"        if GCC_VERSION_12
-       default "14.1.0"        if GCC_VERSION_14
+       default "14.2.0"        if GCC_VERSION_14
        default "13.3.0"
 
 config GCC_USE_DEFAULT_VERSION
index 2161ce72e4a55441960a8a7bb4a6d869b9fcf008..0ccf55bd313ca20d1f4dc7e1fb507e85f69e3f4e 100644 (file)
@@ -42,8 +42,8 @@ ifeq ($(PKG_VERSION),13.3.0)
   PKG_HASH:=0845e9621c9543a13f484e94584a49ffc0129970e9914624235fc1d061a0c083
 endif
 
-ifeq ($(PKG_VERSION),14.1.0)
-  PKG_HASH:=e283c654987afe3de9d8080bc0bd79534b5ca0d681a73a11ff2b5d3767426840
+ifeq ($(PKG_VERSION),14.2.0)
+  PKG_HASH:=a7b39bc69cbf9e25826c5a60ab26477001f7c08d85cec04bc0e29cabed6f3cc9
 endif
 
 PATCH_DIR=../patches-$(GCC_MAJOR_VERSION).x
index 2d65ba1b1f0278a04585ea0a6ffe3333d402005b..2cbffe451724ad1e3937cf9bfe3bd2ff388ca59c 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/gcc/config/mips/mips.cc
 +++ b/gcc/config/mips/mips.cc
-@@ -20444,7 +20444,7 @@ mips_option_override (void)
+@@ -20453,7 +20453,7 @@ mips_option_override (void)
      flag_pcc_struct_return = 0;
  
    /* Decide which rtx_costs structure to use.  */