kernel: r8125: ignore the rss rxnfc log
authorChukun Pan <amadeus@jmu.edu.cn>
Mon, 12 Aug 2024 13:26:01 +0000 (21:26 +0800)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 18 Aug 2024 09:38:40 +0000 (11:38 +0200)
This log is noisy and useless, just ignore it.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
package/kernel/r8125/Makefile
package/kernel/r8125/patches/100-r8125_rss-silence-rxnfc-log.patch [new file with mode: 0644]

index 0b78154c01c3280e9c23915e63b9253a42c7a5cf..9865210e585e49f3fb6c70b737815c11834a0b11 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=r8125
 PKG_VERSION:=9.013.02
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/openwrt/rtl8125/releases/download/$(PKG_VERSION)
diff --git a/package/kernel/r8125/patches/100-r8125_rss-silence-rxnfc-log.patch b/package/kernel/r8125/patches/100-r8125_rss-silence-rxnfc-log.patch
new file mode 100644 (file)
index 0000000..58eb470
--- /dev/null
@@ -0,0 +1,26 @@
+From cd20cf48c0ec2a01fd9f512e25218a6ac8131794 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
+Date: Sat, 17 Aug 2024 22:07:23 +0200
+Subject: [PATCH] r8125_rss: silence rxnfc log
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This log is noisy and useless, just ignore it.
+
+Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
+---
+ src/r8125_rss.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/r8125_rss.c
++++ b/src/r8125_rss.c
+@@ -91,7 +91,7 @@ int rtl8125_get_rxnfc(struct net_device
+         struct rtl8125_private *tp = netdev_priv(dev);
+         int ret = -EOPNOTSUPP;
+-        netif_info(tp, drv, tp->dev, "rss get rxnfc\n");
++        netif_dbg(tp, drv, tp->dev, "rss get rxnfc\n");
+         if (!(dev->features & NETIF_F_RXHASH))
+                 return ret;