ls-mc: select by default for layerscape/armv8_64b
authorRobert Marko <robimarko@gmail.com>
Fri, 11 Apr 2025 21:32:41 +0000 (23:32 +0200)
committerRobert Marko <robimarko@gmail.com>
Sun, 13 Apr 2025 09:25:14 +0000 (11:25 +0200)
Currently, ls-mc package is being included in the individual
profile DEVICE_PACKAGES but using the feature that allows skipping their
inclusion in the end image package list if prefixed with a tilde(~) which
was added in:
377b66990b97 ("build: introduce support to declare skip package")

But it not added to Image Builder so currently trying to build layerscape
device images in Image Builder will fail with:
ERROR: '~ls-mc' is not a valid world dependency, format is name(@tag)([<>~=]version)

So, instead of having to rely on support for skipping package installation
and declaring the ls-mc package in DEVICE_PACKAGES lets select it when
layerscape/armv8_64b target is selected.

Fixes: #18412
Link: https://github.com/openwrt/openwrt/pull/18462
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/layerscape/ls-mc/Makefile

index 31ed1f98dc5902b261b569a87c16053739ee2bca..54b17f3e979dd8ceaf12936fee26dbbbd9350ee1 100644 (file)
@@ -25,6 +25,8 @@ define Package/layerscape-mc
   CATEGORY:=Firmware
   TITLE:=NXP MC firmware
   DEPENDS:=@TARGET_layerscape
+  DEFAULT:=y if TARGET_layerscape_armv8_64b
+  HIDDEN:=1
 endef
 
 define Build/Compile