compat-wireless: fix patches/99-change-makefiles.patch
authorLuis R. Rodriguez <mcgrof@frijolero.org>
Wed, 1 Feb 2012 00:03:18 +0000 (16:03 -0800)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Wed, 1 Feb 2012 00:03:18 +0000 (16:03 -0800)
CONFIG_USB_NET_QMI_WWAN was added and therefore the
respective Makefile, drivers/net/usb/Makefile, needs
to be adjusted to remove that from our list of targets.

If we user our own generated Makefiles for drivers the
advantage is that we would not face this issue when upstream
gets a new driver that our hunk needs to ignore but -- the
disadvantage is that any changes upstream would require a
respective change into compat-wireless. Driver Makefiles
though typically are just copied as-is and never modified.
Its subsystem Makefiles that we tend to have to patch on
this file.

One option would be to somehow annotate upstream targets as
compat-wireless maintained so that we can script out what
targets to leave in.

Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
patches/99-change-makefiles.patch

index a7ddb513afae7805b47864a642fe37dd0b87cfd7..3ab5c73c72816d1583880e5dd5724d0843fcf537 100644 (file)
@@ -15,7 +15,7 @@ only the wireless stuff.
 -obj-$(CONFIG_EEPROM_DIGSY_MTC_CFG) += digsy_mtc_eeprom.o
 --- a/drivers/net/usb/Makefile
 +++ b/drivers/net/usb/Makefile
-@@ -2,31 +2,7 @@
+@@ -2,32 +2,6 @@
  # Makefile for USB Network drivers
  #
  
@@ -46,7 +46,8 @@ only the wireless stuff.
 -obj-$(CONFIG_USB_NET_CX82310_ETH)     += cx82310_eth.o
 -obj-$(CONFIG_USB_NET_CDC_NCM) += cdc_ncm.o
 -obj-$(CONFIG_USB_VL600)               += lg-vl600.o
+-obj-$(CONFIG_USB_NET_QMI_WWAN)        += qmi_wwan.o
+-
 --- a/drivers/net/wireless/Makefile
 +++ b/drivers/net/wireless/Makefile
 @@ -7,18 +7,8 @@ obj-$(CONFIG_IPW2200) += ipw2x00/