add gst-plugins-ugly (#6300)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 7 Dec 2009 16:48:24 +0000 (16:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 7 Dec 2009 16:48:24 +0000 (16:48 +0000)
SVN-Revision: 18678

multimedia/gst-plugins-ugly/Makefile [new file with mode: 0644]
multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch [new file with mode: 0644]
multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch [new file with mode: 0644]

diff --git a/multimedia/gst-plugins-ugly/Makefile b/multimedia/gst-plugins-ugly/Makefile
new file mode 100644 (file)
index 0000000..060a31d
--- /dev/null
@@ -0,0 +1,98 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gst-plugins-ugly
+PKG_VERSION:=0.10.13
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
+PKG_MD5SUM:=1619365247ef9cd7da1cd890285bf87a
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+#export PATH:=$(PKG_BUILD_DIR)/bin:$(TARGET_PATH)
+
+PKG_INSTALL=1
+
+EXTRA_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include \
+       -I$(STAGING_DIR)/usr/include/gtk-2.0/gdk \
+       -I$(STAGING_DIR)/usr/include/gstreamer-0.10
+
+EXTRA_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/gst-plugins-ugly/Default
+  TITLE:=gst-plugins-ugly
+  URL:=http://gstreamer.freedesktop.org/
+endef
+
+define Package/gst-plugins-ugly-lame
+  $(call Package/gst-plugins-ugly/Default)
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  TITLE+= (lame)
+  DEPENDS:=+gstreamer +gst-plugins-base +lame
+endef
+
+define Package/gst-plugins-ugly-lame/description
+       gstreamer MP3 encoder plugin
+endef
+
+define Package/gst-plugins-ugly-mad
+  $(call Package/gst-plugins-ugly/Default)
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  TITLE+= (mad)
+  DEPENDS:=+gstreamer +gst-plugins-base +libmad +libid3tag
+endef
+
+define Package/gst-plugins-ugly-mad/description
+=
+       gstreamer MP3 decoder plugins
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-pango \
+               --disable-gnome_vfs \
+               --disable-examples \
+               --disable-cdparanoia \
+               --disable-libvisual \
+               --disable-oggtest \
+               --disable-vorbistest \
+               --disable-freetypetest \
+               --without-x \
+       )
+       mkdir -p $(PKG_BUILD_DIR)/bin
+       touch $(PKG_BUILD_DIR)/bin/gtkdoc-reugly
+       chmod +x $(PKG_BUILD_DIR)/bin/gtkdoc-reugly
+endef
+
+define Package/gst-plugins-ugly-lame/install
+       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgstlame.so \
+               $(1)/usr/lib/gstreamer-0.10
+endef
+
+define Package/gst-plugins-ugly-mad/install
+       $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/libgstmad.so \
+               $(1)/usr/lib/gstreamer-0.10
+endef
+
+$(eval $(call BuildPackage,gst-plugins-ugly-lame))
+$(eval $(call BuildPackage,gst-plugins-ugly-mad))
diff --git a/multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch b/multimedia/gst-plugins-ugly/patches/020-dont_build_docs.patch
new file mode 100644 (file)
index 0000000..aef5921
--- /dev/null
@@ -0,0 +1,24 @@
+diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/Makefile.am gst-plugins-ugly-0.10.13/Makefile.am
+--- gst-plugins-ugly-0.10.13-vanilla/Makefile.am       2009-11-28 15:17:59.253116063 -0500
++++ gst-plugins-ugly-0.10.13/Makefile.am       2009-11-28 15:19:16.508246874 -0500
+@@ -1,7 +1,7 @@
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext docs m4 tests common po
++      gst-libs gst ext m4 tests common po
+ # include before EXTRA_DIST for win32 assignment
+ include $(top_srcdir)/common/win32.mak
+diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/Makefile.in gst-plugins-ugly-0.10.13/Makefile.in
+--- gst-plugins-ugly-0.10.13-vanilla/Makefile.in       2009-11-28 15:17:59.208114358 -0500
++++ gst-plugins-ugly-0.10.13/Makefile.in       2009-11-28 15:19:23.945116771 -0500
+@@ -356,7 +356,7 @@
+ top_srcdir = @top_srcdir@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+ SUBDIRS = \
+-      gst-libs gst ext docs m4 tests common po
++      gst-libs gst ext m4 tests common po
+ # the MANIFEST contains all win32 related files that should be disted
diff --git a/multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch b/multimedia/gst-plugins-ugly/patches/030-no_shave-make.patch
new file mode 100644 (file)
index 0000000..0695a22
--- /dev/null
@@ -0,0 +1,16 @@
+diff -u --recursive gst-plugins-ugly-0.10.13-vanilla/common/shave-libtool.in gst-plugins-ugly-0.10.13/common/shave-libtool.in
+--- gst-plugins-ugly-0.10.13-vanilla/common/shave-libtool.in   2009-11-28 15:17:59.166114391 -0500
++++ gst-plugins-ugly-0.10.13/common/shave-libtool.in   2009-11-28 15:20:46.244261210 -0500
+@@ -41,12 +41,9 @@
+ case "$mode" in
+ compile)
+-    # shave will be called and print the actual CC/CXX/LINK line
+-    preserved_args="$preserved_args --shave-mode=$mode"
+     pass_though=1
+     ;;
+ link)
+-    preserved_args="$preserved_args --shave-mode=$mode"
+     Q="  LINK  "
+     ;;
+ *)