dtc: Update to 1.7.1
authorAndreas Gnau <andreas.gnau@iopsys.eu>
Mon, 16 Sep 2024 22:07:46 +0000 (00:07 +0200)
committerRobert Marko <robimarko@gmail.com>
Thu, 19 Sep 2024 11:31:32 +0000 (13:31 +0200)
Update to dtc to 1.7.1. Change tarball to gzip and drop upstreamed patch
010-both-libraries.patch. Disable tests.

Changes sinve v1.7.0 include:
 * dtc
   * Fix check for 10-bit I2C addresses
   * Improve documentation of -@ option
   * Update to libyaml >= 0.2.3
   * Improvements & fixes for device graph checks
   * Add -L / --local-fixups option
   * Add check for length of interrupt-map properties
 * libfdt
   * Add fdt_path_getprop_namelen()
   * Add fdt_get_symbol() and fdt_get_symbol_namelen()
   * Correct documentation of fdt_path_offset()
   * Correct documentation of fdt_appendprop_addrrange()
   * Validate aliases is fdt_get_alias_namelen()
   * Don't overwrite phandles when applying overlays
   * Require Python 3
 * pylibfdt
   * Support boolean properties
   * Fixes for current Python versions
 * General
   * Assorted bugfixes
   * Assorted build improvements
   * Assorted typo fixes in docs
   * Some additional testcases
   * Move to GitHub Actions based CI

Signed-off-by: Andreas Gnau <andreas.gnau@iopsys.eu>
Link: https://github.com/openwrt/openwrt/pull/16411
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/utils/dtc/Makefile
package/utils/dtc/patches/010-both-libraries.patch [deleted file]

index ea970e200a68134a88f4767f91d140c7d7985904..8b5eeccfa571565fff441544ef87ade5c8e02966 100644 (file)
@@ -5,11 +5,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dtc
-PKG_VERSION:=1.7.0
-PKG_RELEASE:=3
+PKG_VERSION:=1.7.1
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=29edce3d302a15563d8663198bbc398c5a0554765c83830d0d4c0409d21a16c4
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=9532f10098455711a4da37816fd567dfc8523bb01f59ad6c44887a112e553d9e
 PKG_SOURCE_URL:=@KERNEL/software/utils/dtc
 
 PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
@@ -88,6 +88,7 @@ define Package/libfdt/install
 endef
 
 MESON_ARGS += \
+       -Dtests=false \
        -Dtools=true \
        -Dyaml=disabled \
        -Dvalgrind=disabled \
diff --git a/package/utils/dtc/patches/010-both-libraries.patch b/package/utils/dtc/patches/010-both-libraries.patch
deleted file mode 100644 (file)
index ccc547b..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From da39ee0e68b6d9293133a7c41c6cf73354dce337 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Wed, 21 Feb 2024 13:57:56 -0800
-Subject: [PATCH] libfdt: rework shared/static libraries
-
-Instead of creating 2 libraries manualy, just call both_libraries and
-link to the appropriate one as requested.
-
-Fixes compilation when passing -Ddefault_libraries=both as the
-static_library name is duplicated.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
-Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
----
- libfdt/meson.build | 17 +++++------------
- 1 file changed, 5 insertions(+), 12 deletions(-)
-
---- a/libfdt/meson.build
-+++ b/libfdt/meson.build
-@@ -16,7 +16,7 @@ sources = files(
-   'fdt_wip.c',
- )
--libfdt = library(
-+libfdt = both_libraries(
-   'fdt', sources,
-   version: '1.6.0',
-   link_args: ['-Wl,--no-undefined', version_script],
-@@ -24,17 +24,12 @@ libfdt = library(
-   install: true,
- )
--libfdt_a = static_library(
--  'fdt', sources,
--  install: true,
--)
--
- libfdt_inc = include_directories('.')
- if static_build
--  link_with = libfdt_a
-+  link_with = libfdt.get_static_lib()
- else
--  link_with = libfdt
-+  link_with = libfdt.get_shared_lib()
- endif
- libfdt_dep = declare_dependency(