Add coreutils 6.9 from #1753
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 16:52:37 +0000 (16:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Nov 2008 16:52:37 +0000 (16:52 +0000)
SVN-Revision: 13153

utils/coreutils/Makefile [new file with mode: 0644]

diff --git a/utils/coreutils/Makefile b/utils/coreutils/Makefile
new file mode 100644 (file)
index 0000000..0c7e95b
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=coreutils
+PKG_VERSION:=6.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/coreutils/
+PKG_MD5SUM:=c9607d8495f16e98906e7ed2d9751a06
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/coreutils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=The GNU core utilities
+  URL:=http://www.gnu.org/software/coreutils/
+endef
+       
+define Package/coreutils/description
+       Full versions of standard GNU utilities.  Normally, you would not
+       use this package, since the functionality in BusyBox is more than
+        sufficient and much smaller.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               SHELL="/bin/bash" \
+               all install
+endef
+
+define Package/coreutils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,coreutils))