projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a5b5812
)
use an if block on the whole configure command
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 30 Aug 2006 10:30:14 +0000
(10:30 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 30 Aug 2006 10:30:14 +0000
(10:30 +0000)
SVN-Revision: 4717
openwrt/include/package.mk
patch
|
blob
|
history
diff --git
a/openwrt/include/package.mk
b/openwrt/include/package.mk
index 8d905093055426dacee1dc251af306564ab6b8b7..9a947f358248338773337f374e0d996ba8a45b8e 100644
(file)
--- a/
openwrt/include/package.mk
+++ b/
openwrt/include/package.mk
@@
-263,7
+263,7
@@
endef
define Build/Configure/Default
@(cd $(PKG_BUILD_DIR)/$(3); \
-
[ \! -x configure ] ||
\
+
if [ -x configure ]; then
\
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@
-287,6
+287,7
@@
define Build/Configure/Default
--infodir=/usr/info \
$(DISABLE_NLS) \
$(1); \
+ fi; \
)
endef