projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
48db59f
)
build: allow the package maintainer info to be specified globally for a source package
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 8 Oct 2012 11:40:57 +0000
(11:40 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 8 Oct 2012 11:40:57 +0000
(11:40 +0000)
SVN-Revision: 33659
include/package-defaults.mk
patch
|
blob
|
history
diff --git
a/include/package-defaults.mk
b/include/package-defaults.mk
index e2ce863166f74d47464a574ad701008b2a651607..45a92cf6e9d9522193e899ff3dd8d495a335cf4b 100644
(file)
--- a/
include/package-defaults.mk
+++ b/
include/package-defaults.mk
@@
-13,6
+13,8
@@
else
PKG_FIXUP_DEPENDS = $(2)
endif
+PKG_MAINTAINER ?= OpenWrt Developers Team <openwrt-devel@openwrt.org>
+
define Package/Default
CONFIGFILE:=
SECTION:=opt
@@
-21,7
+23,7
@@
define Package/Default
MDEPENDS:=
PROVIDES:=
EXTRA_DEPENDS:=
- MAINTAINER:=
OpenWrt Developers Team <openwrt-devel@openwrt.org>
+ MAINTAINER:=
$(PKG_MAINTAINER)
SOURCE:=$(patsubst $(TOPDIR)/%,%,$(CURDIR))
ifneq ($(PKG_VERSION),)
ifneq ($(PKG_RELEASE),)