projects
/
openwrt
/
staging
/
blocktrron.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6bac7bb
)
nls.mk: fixup cmake packages
author
Rosen Penev
<rosenp@gmail.com>
Tue, 22 Nov 2022 01:02:31 +0000
(17:02 -0800)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 26 Nov 2022 23:52:06 +0000
(
00:52
+0100)
Instead of manually overriding every cmake package that uses iconv or
gettext's paths, add the prefix in here so that at least FindIconv.cmake
works. Fixes compilation with BUILD_NLS.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/nls.mk
patch
|
blob
|
history
diff --git
a/include/nls.mk
b/include/nls.mk
index 90fc27660f9d6b4c2b94669be3c7ebe82ec1b035..f054d2bb68af77b277e6de8f0dcca13287a1c9f8 100644
(file)
--- a/
include/nls.mk
+++ b/
include/nls.mk
@@
-10,6
+10,7
@@
ifeq ($(CONFIG_BUILD_NLS),y)
INTL_PREFIX:=$(STAGING_DIR)/usr/lib/libintl-full
INTL_FULL:=1
+ CMAKE_OPTIONS += -DCMAKE_PREFIX_PATH="$(ICONV_PREFIX);$(INTL_PREFIX)"
else
ICONV_PREFIX:=
ICONV_FULL:=