[packages] sshtunnel: small makefile fix
authorNuno Goncalves <nunojpg@gmail.com>
Sun, 19 Dec 2010 01:09:10 +0000 (01:09 +0000)
committerNuno Goncalves <nunojpg@gmail.com>
Sun, 19 Dec 2010 01:09:10 +0000 (01:09 +0000)
SVN-Revision: 24694

net/sshtunnel/Makefile

index 44c4fc79082c43ed3cafc6f9346415200c4b91d4..f75fcbbfb985e75093b9c7c28d82994887fdb4db 100644 (file)
@@ -34,9 +34,12 @@ define Build/Compile
 endef
 
 define Package/sshtunnel/install
-       $(CP) ./files/uci_sshtunnel $(1)/etc/config/sshtunnel
-       $(CP) ./files/initd_sshtunnel $(1)/etc/initd/sshtunnel
-       $(CP) ./files/sshtunnel.sh $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/initd_sshtunnel $(1)/etc/init.d/sshtunnel
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) ./files/sshtunnel.sh $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/uci_sshtunnel $(1)/etc/config/sshtunnel
 endef
 
 $(eval $(call BuildPackage,sshtunnel))