include $(TOPDIR)/rules.mk
PKG_NAME:=gettext
-PKG_VERSION:=0.17
+PKG_VERSION:=0.18.1.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=58a2bc6d39c0ba57823034d55d65d606
+PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
PKG_FIXUP:=libtool
PKG_INSTALL:=1
-diff -pruN gettext-0.17.orig/autoconf-lib-link/Makefile.in gettext-0.17/autoconf-lib-link/Makefile.in
---- gettext-0.17.orig/autoconf-lib-link/Makefile.in 2009-05-19 17:11:00.057467286 +0200
-+++ gettext-0.17/autoconf-lib-link/Makefile.in 2009-05-19 17:12:04.539791314 +0200
-@@ -206,7 +206,7 @@ EXTRA_DIST = config.rpath
- DISTCLEANFILES = build-aux/config.guess build-aux/config.sub \
- build-aux/install-sh build-aux/ltmain.sh build-aux/missing \
- build-aux/config.rpath
--SUBDIRS = m4 tests
-+SUBDIRS = m4
-
- # Subdirectories with separate autoconfiguration.
- CONFIGURES_RPATHX = $(srcdir)/tests/rpathx/Makefile.in $(srcdir)/tests/rpathx/aclocal.m4 $(srcdir)/tests/rpathx/configure
-diff -pruN gettext-0.17.orig/gettext-runtime/Makefile.in gettext-0.17/gettext-runtime/Makefile.in
---- gettext-0.17.orig/gettext-runtime/Makefile.in 2009-05-19 17:10:59.798239310 +0200
-+++ gettext-0.17/gettext-runtime/Makefile.in 2009-05-19 17:12:40.225999245 +0200
+--- a/gettext-runtime/Makefile.in 2009-05-19 17:10:59.798239310 +0200
++++ b/gettext-runtime/Makefile.in 2009-05-19 17:12:40.225999245 +0200
@@ -154,7 +154,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
ETAGS = etags
CTAGS = ctags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
-diff -pruN gettext-0.17.orig/gettext-tools/Makefile.in gettext-0.17/gettext-tools/Makefile.in
---- gettext-0.17.orig/gettext-tools/Makefile.in 2009-05-19 17:11:00.269723630 +0200
-+++ gettext-0.17/gettext-tools/Makefile.in 2009-05-19 17:14:09.041478317 +0200
-@@ -724,7 +724,7 @@ top_builddir = @top_builddir@
+--- a/gettext-tools/Makefile.in
++++ b/gettext-tools/Makefile.in
+@@ -1248,7 +1248,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
- ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4 -I gnulib-m4 -I libgettextpo/gnulib-m4
+ ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
+++ /dev/null
-diff -pruN gettext-0.17.orig/gettext-tools/gnulib-lib/Makefile.in gettext-0.17/gettext-tools/gnulib-lib/Makefile.in
---- gettext-0.17.orig/gettext-tools/gnulib-lib/Makefile.in 2009-05-19 17:17:24.413508248 +0200
-+++ gettext-0.17/gettext-tools/gnulib-lib/Makefile.in 2009-05-19 17:19:06.457520598 +0200
-@@ -1330,7 +1330,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
- if test -f $$p; then \
- f=$(am__strip_dir) \
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
-- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
- else :; fi; \
- done
-
-diff -pruN gettext-0.17.orig/gettext-tools/libgettextpo/Makefile.in gettext-0.17/gettext-tools/libgettextpo/Makefile.in
---- gettext-0.17.orig/gettext-tools/libgettextpo/Makefile.in 2009-05-19 17:17:24.125764150 +0200
-+++ gettext-0.17/gettext-tools/libgettextpo/Makefile.in 2009-05-19 17:23:11.101467088 +0200
-@@ -953,7 +953,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
- if test -f $$p; then \
- f=$(am__strip_dir) \
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
-- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
- else :; fi; \
- done
-
-diff -pruN gettext-0.17.orig/gettext-tools/src/Makefile.in gettext-0.17/gettext-tools/src/Makefile.in
---- gettext-0.17.orig/gettext-tools/src/Makefile.in 2009-05-19 17:17:24.718249813 +0200
-+++ gettext-0.17/gettext-tools/src/Makefile.in 2009-05-19 17:24:34.473723917 +0200
-@@ -1337,7 +1337,6 @@ install-libLTLIBRARIES: $(lib_LTLIBRARIE
- if test -f $$p; then \
- f=$(am__strip_dir) \
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
-- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
- else :; fi; \
- done
-
-@@ -1369,7 +1368,6 @@ install-binPROGRAMS: $(bin_PROGRAMS)
- ; then \
- f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
- echo " $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
-- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
- else :; fi; \
- done
-
+++ /dev/null
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-#
-# T2 SDE: package/.../gettext/wchar-fix.patch
-# Copyright (C) 2008 The T2 SDE Project
-#
-# More information can be found in the files COPYING and README.
-#
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-# --- T2-COPYRIGHT-NOTE-BEGIN ---
-# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
-#
-# T2 SDE: package/.../gettext/wchar-fix.patch
-# Copyright (C) 2008 The T2 SDE Project
-#
-# More information can be found in the files COPYING and README.
-#
-# This patch file is dual-licensed. It is available under the license the
-# patched project is licensed under, as long as it is an OpenSource license
-# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
-# of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-# --- T2-COPYRIGHT-NOTE-END ---
-#
-# Taken from: http://svn.exactcode.de/t2/trunk/package/base/gettext/wchar-fix.patch
-#
-
-diff -pruN gettext-0.17.orig//gettext-runtime/gnulib-lib/wchar.in.h gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h
---- gettext-0.17.orig//gettext-runtime/gnulib-lib/wchar.in.h 2010-02-17 15:36:18.822918689 +0100
-+++ gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h 2010-02-17 15:38:37.686548691 +0100
-@@ -26,6 +26,14 @@
- * the declaration of wcwidth().
- */
-
-+#ifdef __need_mbstate_t
-+/* Special invocation convention inside glibc header files. */
-+
-+#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
-+
-+#else
-+/* Normal invocation convention. */
-+
- #ifndef _GL_WCHAR_H
-
- /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
-@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
-
- #endif /* _GL_WCHAR_H */
- #endif /* _GL_WCHAR_H */
-+#endif
-diff -pruN gettext-0.17.orig//gettext-tools/gnulib-lib/wchar.in.h gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h
---- gettext-0.17.orig//gettext-tools/gnulib-lib/wchar.in.h 2010-02-17 15:36:21.302471149 +0100
-+++ gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h 2010-02-17 15:40:10.667180066 +0100
-@@ -26,6 +26,14 @@
- * the declaration of wcwidth().
- */
-
-+#ifdef __need_mbstate_t
-+/* Special invocation convention inside glibc header files. */
-+
-+#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
-+
-+#else
-+/* Normal invocation convention. */
-+
- #ifndef _GL_WCHAR_H
-
- /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
-@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
-
- #endif /* _GL_WCHAR_H */
- #endif /* _GL_WCHAR_H */
-+#endif
-diff -pruN gettext-0.17.orig//gettext-tools/libgettextpo/wchar.in.h gettext-0.17/gettext-tools/libgettextpo/wchar.in.h
---- gettext-0.17.orig//gettext-tools/libgettextpo/wchar.in.h 2010-02-17 15:36:19.870408142 +0100
-+++ gettext-0.17/gettext-tools/libgettextpo/wchar.in.h 2010-02-17 15:40:48.206658667 +0100
-@@ -26,6 +26,14 @@
- * the declaration of wcwidth().
- */
-
-+#ifdef __need_mbstate_t
-+/* Special invocation convention inside glibc header files. */
-+
-+#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
-+
-+#else
-+/* Normal invocation convention. */
-+
- #ifndef _GL_WCHAR_H
-
- /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
-@@ -80,3 +88,4 @@ extern int wcwidth (int /* actually wcha
-
- #endif /* _GL_WCHAR_H */
- #endif /* _GL_WCHAR_H */
-+#endif
+++ /dev/null
-diff -pruN gettext-0.17.orig//gettext-runtime/intl/Makefile.in gettext-0.17/gettext-runtime/intl/Makefile.in
---- gettext-0.17.orig//gettext-runtime/intl/Makefile.in 2010-02-17 16:33:29.922429524 +0100
-+++ gettext-0.17/gettext-runtime/intl/Makefile.in 2010-02-17 16:40:47.294419311 +0100
-@@ -191,7 +191,7 @@ libintl.a libgnuintl.a: $(OBJECTS)
- $(RANLIB) $@
-
- libintl.la libgnuintl.la: $(OBJECTS) $(OBJECTS_RES_@WOE32@)
-- $(LIBTOOL) --mode=link \
-+ $(LIBTOOL) --tag=CC --mode=link \
- $(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \
- $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) @LTLIBTHREAD@ @LTLIBC@ \
- $(OBJECTS_RES_@WOE32@) \
-@@ -219,59 +219,59 @@ LTV_AGE=0
- rm -f $*.h
-
- bindtextdom.lo: $(srcdir)/bindtextdom.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/bindtextdom.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/bindtextdom.c
- dcgettext.lo: $(srcdir)/dcgettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcgettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcgettext.c
- dgettext.lo: $(srcdir)/dgettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dgettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dgettext.c
- gettext.lo: $(srcdir)/gettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/gettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/gettext.c
- finddomain.lo: $(srcdir)/finddomain.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/finddomain.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/finddomain.c
- hash-string.lo: $(srcdir)/hash-string.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/hash-string.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/hash-string.c
- loadmsgcat.lo: $(srcdir)/loadmsgcat.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/loadmsgcat.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/loadmsgcat.c
- localealias.lo: $(srcdir)/localealias.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localealias.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localealias.c
- textdomain.lo: $(srcdir)/textdomain.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/textdomain.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/textdomain.c
- l10nflist.lo: $(srcdir)/l10nflist.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/l10nflist.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/l10nflist.c
- explodename.lo: $(srcdir)/explodename.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/explodename.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/explodename.c
- dcigettext.lo: $(srcdir)/dcigettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcigettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcigettext.c
- dcngettext.lo: $(srcdir)/dcngettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dcngettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dcngettext.c
- dngettext.lo: $(srcdir)/dngettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/dngettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/dngettext.c
- ngettext.lo: $(srcdir)/ngettext.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/ngettext.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/ngettext.c
- plural.lo: $(srcdir)/plural.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/plural.c
- plural-exp.lo: $(srcdir)/plural-exp.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/plural-exp.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/plural-exp.c
- localcharset.lo: $(srcdir)/localcharset.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localcharset.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localcharset.c
- lock.lo: $(srcdir)/lock.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/lock.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/lock.c
- relocatable.lo: $(srcdir)/relocatable.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/relocatable.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/relocatable.c
- langprefs.lo: $(srcdir)/langprefs.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/langprefs.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/langprefs.c
- localename.lo: $(srcdir)/localename.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/localename.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/localename.c
- log.lo: $(srcdir)/log.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/log.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/log.c
- printf.lo: $(srcdir)/printf.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/printf.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/printf.c
- version.lo: $(srcdir)/version.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/version.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/version.c
- osdep.lo: $(srcdir)/osdep.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/osdep.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/osdep.c
- intl-compat.lo: $(srcdir)/intl-compat.c
-- $(LIBTOOL) --mode=compile $(COMPILE) $(srcdir)/intl-compat.c
-+ $(LIBTOOL) --tag=CC --mode=compile $(COMPILE) $(srcdir)/intl-compat.c
-
- # This rule is executed only on Woe32 systems.
- # The following sed expressions come from the windres-options script. They are
--- /dev/null
+--- a/gettext-tools/gnulib-lib/spawn.h
++++ b/gettext-tools/gnulib-lib/spawn.h
+@@ -32,8 +32,10 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#ifndef __GLIBC__ || __UCLIBC__
+ # include <sched.h>
++#endif
++#ifndef __GLIBC__
+ # include <signal.h>
+ #endif
+