readline: override termlib for host
authorRosen Penev <rosenp@gmail.com>
Tue, 9 Jul 2024 21:06:57 +0000 (14:06 -0700)
committerRobert Marko <robimarko@gmail.com>
Wed, 10 Jul 2024 07:39:32 +0000 (09:39 +0200)
For some reason, it's not working right locally. Override as is done
with the target build.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15916
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/libs/readline/Makefile

index 3ab28712af426ed25cced375704db84bc7857174..11b9e0172f844a9499aeed776a397e3c5529f293 100644 (file)
@@ -48,6 +48,9 @@ endef
 HOST_CONFIGURE_ARGS += --disable-shared --with-pic
 CONFIGURE_ARGS += --with-curses --disable-install-examples
 
+HOST_CONFIGURE_VARS += \
+       bash_cv_termcap_lib=libncurses
+
 CONFIGURE_VARS += \
        bash_cv_wcwidth_broken=no \
        bash_cv_func_sigsetjmp=yes \