projects
/
openwrt
/
staging
/
ansuel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
141f9e3
)
include/target.mk: Only set usb feature flag for a target if there is a HCD
author
Lars-Peter Clausen
<lars@metafoo.de>
Thu, 25 Mar 2010 15:04:44 +0000
(15:04 +0000)
committer
Lars-Peter Clausen
<lars@metafoo.de>
Thu, 25 Mar 2010 15:04:44 +0000
(15:04 +0000)
SVN-Revision: 20425
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index 61ff2d21aa75eb197c9cd7431c47e0bfa50cfd09..5eb8547cc2ec5c8f0404490887e9f0dc2813d899 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-148,7
+148,9
@@
ifeq ($(DUMP),1)
FEATURES += pcie
endif
ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
- FEATURES += usb
+ ifneq ($(CONFIG_USB_ARCH_HAS_HCD)$(CONFIG_USB_EHCI_HCD),)
+ FEATURES += usb
+ endif
endif
ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)
FEATURES += pcmcia