packages/arpwatch: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:25 +0000 (23:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:25 +0000 (23:43 +0000)
SVN-Revision: 28912

net/arpwatch/Makefile
net/arpwatch/files/arpwatch.init

index fe981fef5a5f021a56bd92217e119a9ba701c59a..20b1959b608a9abd56410924689e04ed7a7a31dd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arpwatch
 PKG_VERSION:=2.1a15
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.free.fr/.mirrors1/ftp.gentoo.org/distfiles/
index 56d13e3addfedff376ed37783768499fffbe3690..b05692b5c90a233c947f5b881b05bf25798e8945 100644 (file)
@@ -1,10 +1,12 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=90
 
-start () {
-       arpwatch -f /etc/arpwatch/arp.dat -i br-lan
+start() {
+       service_start /usr/sbin/arpwatch -f /etc/arpwatch/arp.dat -i br-lan
 }
 
 stop() {
-       killall arpwatch
+       service_stop /usr/sbin/arpwatch
 }