projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
733f2f8
)
mpc85xx: copy the fdt for mpc8548cds to $(BIN_DIR)
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 16 Mar 2011 18:04:54 +0000
(18:04 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 16 Mar 2011 18:04:54 +0000
(18:04 +0000)
SVN-Revision: 26191
target/linux/mpc85xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/mpc85xx/image/Makefile
b/target/linux/mpc85xx/image/Makefile
index bb9904572c0ef499c544fb15fcaf46832ae336b2..a5d1acbd5c8723d65dc88f1036dde164080742c5 100644
(file)
--- a/
target/linux/mpc85xx/image/Makefile
+++ b/
target/linux/mpc85xx/image/Makefile
@@
-7,12
+7,15
@@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+DTS_TARGETS = mpc8548cds
+
define Image/Prepare
cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
endef
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ $(foreach dts,$(DTS_TARGETS),$(LINUX_DIR)/scripts/dtc/dtc -I dts -O dtb $(LINUX_DIR)/arch/powerpc/boot/dts/$(dts).dts > $(BIN_DIR)/$(IMG_PREFIX)-$(dts).fdt)
endef
define Image/Build/ext2