utils: mtd-utils: update to 2.2.0
authorRobert Marko <robimarko@gmail.com>
Tue, 25 Jun 2024 12:14:43 +0000 (14:14 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 26 Jun 2024 07:23:27 +0000 (09:23 +0200)
Release notes:
https://lists.infradead.org/pipermail/linux-mtd/2024-March/104058.html

mtd-utils are currently depending on zlib, however it is not expressed
as a dependency and it is somehow being only pulled-in by lincurses-devel
so mtd-utils were able to compile.

Since 2.2.0 zlib is optional so lets disable support for it like for other
compressors since we dont package the mkfs.ubifs or mkfs.jffs2 that
are only users of compressors anyway.

Link: https://github.com/openwrt/openwrt/pull/15802
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/utils/mtd-utils/Makefile

index 0e2c16dd2bf73efc21d7f29b69345a8ebe78453e..a73f5e1eb1f1b1b8f8f6bfc1dce4b50ad8ac3cf1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtd-utils
-PKG_VERSION:=2.1.6
-PKG_RELEASE:=3
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://infraroot.at/pub/mtd/
-PKG_HASH:=c1d853bc4adf83bcabd2792fc95af33bdd8643c97e8f7b3f0180af36af76f0e5
+PKG_HASH:=250d082f67375ca8451b5fcfc9a23a53ced3ebebd8312c288daf2507bbab1324
 
 PKG_INSTALL:=1
 
@@ -62,7 +62,8 @@ CONFIGURE_ARGS += \
        --without-crypto \
        --without-xattr \
        --without-zstd \
-       --without-lzo
+       --without-lzo \
+       --without-zlib
 
 define Package/ubi-utils/install
        $(INSTALL_DIR) $(1)/usr/sbin