projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5b4fc38
)
sparc64: Export __node_distance.
author
David S. Miller
<davem@davemloft.net>
Fri, 26 Oct 2018 22:11:56 +0000
(15:11 -0700)
committer
David S. Miller
<davem@davemloft.net>
Fri, 26 Oct 2018 22:11:56 +0000
(15:11 -0700)
Some drivers reference it via node_distance(), for example the
NVME host driver core.
ERROR: "__node_distance" [drivers/nvme/host/nvme-core.ko] undefined!
make[1]: *** [scripts/Makefile.modpost:92: __modpost] Error 1
Signed-off-by: David S. Miller <davem@davemloft.net>
arch/sparc/mm/init_64.c
patch
|
blob
|
history
diff --git
a/arch/sparc/mm/init_64.c
b/arch/sparc/mm/init_64.c
index f396048a0d6808f7faddc7addbd6c461e3c835ad..39822f611c01503211413a28d8c3492de60e6e26 100644
(file)
--- a/
arch/sparc/mm/init_64.c
+++ b/
arch/sparc/mm/init_64.c
@@
-1383,6
+1383,7
@@
int __node_distance(int from, int to)
}
return numa_latency[from][to];
}
+EXPORT_SYMBOL(__node_distance);
static int __init find_best_numa_node_for_mlgroup(struct mdesc_mlgroup *grp)
{