include $(TOPDIR)/rules.mk
PKG_NAME:=aiccu
-PKG_VERSION:=20070107
+PKG_VERSION:=20070115
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-PKG_MD5SUM:=67a6d55ef2d6e88a3f17bcb5eec02c61
+PKG_MD5SUM:=0df76e92eb34f4ce8aa3cfcf6896f271
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-diff -ruN aiccu-old/unix-console/Makefile aiccu-new/unix-console/Makefile
---- aiccu-old/unix-console/Makefile 2007-01-15 12:22:48.000000000 +0100
-+++ aiccu-new/unix-console/Makefile 2007-01-15 12:33:13.000000000 +0100
+diff -urN aiccu/unix-console/Makefile aiccu.new/unix-console/Makefile
+--- aiccu/unix-console/Makefile 2007-01-15 12:04:27.000000000 +0100
++++ aiccu.new/unix-console/Makefile 2007-01-18 15:08:28.000000000 +0100
@@ -10,6 +10,9 @@
- # $Date: 2007-01-11 00:28:45 $
+ # $Date: 2007-01-15 11:04:27 $
# **********************************************************/
+OS_NAME=$(shell uname)
# Used by TIC to secure that communication
# Currently defaultly builds only on Linux, but other platforms might easily also support it
-ifeq ($(shell uname | grep -c "Linux"),1)
-+ifneq ($(HAVE_GNUTLS),)
++ifneq ($(HAEVE_GNUTLS),)
CFLAGS += -D AICCU_GNUTLS
LDFLAGS += -lgnutls
endif
# NetBSD
-ifeq ($(shell uname | grep -c "NetBSD"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "NetBSD"),1)
- CFLAGS += -D_NETBSD -D NEED_IFHEAD -D AICCU_TYPE="\"kame\""
- SRCS += ../common/aiccu_kame.c
- OBJS += ../common/aiccu_kame.o
-@@ -87,10 +90,10 @@
+ CFLAGS += -D_NETBSD -D AICCU_TYPE="\"kame\""
+
+ # Check if net/if_tun.h has TUNSIFHEAD and enable support for it
+@@ -97,10 +100,10 @@
endif
# OpenBSD
CFLAGS += -D AICCU_TYPE="\"openbsd2\""
SRCS += ../common/aiccu_openbsd2.c
OBJS += ../common/aiccu_openbsd2.o
-@@ -104,7 +107,7 @@
+@@ -114,7 +117,7 @@
endif
# Darwin
CFLAGS += -D_DARWIN -D NEED_IFHEAD -D AICCU_TYPE="\"darwin\""
SRCS += ../common/aiccu_darwin.c
OBJS += ../common/aiccu_darwin.o
-@@ -112,7 +115,7 @@
+@@ -122,7 +125,7 @@
endif
# SunOS / Solaris
CFLAGS += -D_SUNOS -D AICCU_TYPE="\"sunos\""
SRCS += ../common/aiccu_sunos.c
OBJS += ../common/aiccu_sunos.o
-@@ -120,7 +123,7 @@
+@@ -130,7 +133,7 @@
endif
# AIX