curl: update to version 7.21.3
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 01:45:05 +0000 (01:45 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 22 Dec 2010 01:45:05 +0000 (01:45 +0000)
SVN-Revision: 24772

libs/curl/Makefile
libs/curl/patches/100-cross_compile.patch
libs/curl/patches/510-no_sslv2.patch

index 1f678ba02fe0d1494ce699232bc42490e04c3d60..db6617b5be66de772312c1bfa9b068538c15b86d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.21.2
+PKG_VERSION:=7.21.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=ca96df88e044c7c25d19692ec8b250b2
+PKG_MD5SUM:=5b57fee22090b5c43a6886fdd35af2ce
 
 PKG_FIXUP:=libtool
 PKG_BUILD_PARALLEL:=1
index 58404c6f21b02e7243398a2b9fbb3b214b3af6a6..9cccf249dfd2871217c87c6f88cb068290f23cdf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -19785,17 +19785,6 @@ $as_echo "no" >&6; }
+@@ -19786,17 +19786,6 @@ $as_echo "no" >&6; }
  fi
  rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
    fi
@@ -18,7 +18,7 @@
  fi
  
  
-@@ -20251,21 +20240,6 @@ else
+@@ -20252,21 +20241,6 @@ else
           CPPFLAGS="$CLEANCPPFLAGS"
  
  fi
@@ -42,7 +42,7 @@
    fi
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1494,19 +1494,6 @@ if test X"$OPT_SSL" != Xno; then
+@@ -1497,19 +1497,6 @@ if test X"$OPT_SSL" != Xno; then
        AC_MSG_RESULT([no])
      ])
    fi
@@ -62,7 +62,7 @@
  fi
  
  dnl **********************************************************************
-@@ -1714,22 +1701,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
+@@ -1717,22 +1704,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
           LIBS="$CLEANLIBS"
           CPPFLAGS="$CLEANCPPFLAGS"
         ])
index 3a7ef4d8a3f19ea62fd8ce977e3f0292b8ddb23b..b1ac97f1392793d836c1e5ad0d6cdae1082a9416 100644 (file)
@@ -15,7 +15,7 @@
      use_sni(FALSE);
 --- a/src/main.c
 +++ b/src/main.c
-@@ -883,7 +883,9 @@ static void help(void)
+@@ -888,7 +888,9 @@ static void help(void)
      " -y/--speed-time    Time needed to trig speed-limit abort. Defaults to 30",
      "    --ssl           Try SSL/TLS (FTP, IMAP, POP3, SMTP)",
      "    --ssl-reqd      Require SSL/TLS (FTP, IMAP, POP3, SMTP)",
@@ -25,7 +25,7 @@
      " -3/--sslv3         Use SSLv3 (SSL)",
      "    --stderr <file> Where to redirect stderr. - means stdout",
      "    --tcp-nodelay   Use the TCP_NODELAY option",
-@@ -2445,10 +2447,12 @@ static ParameterError getparameter(char 
+@@ -2470,10 +2472,12 @@ static ParameterError getparameter(char
        /* TLS version 1 */
        config->ssl_version = CURL_SSLVERSION_TLSv1;
        break;