uboot-sunxi: bump to 2025.01
authorZoltan HERPAI <wigyori@uid0.hu>
Sun, 16 Feb 2025 21:18:13 +0000 (21:18 +0000)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 18 Feb 2025 15:28:55 +0000 (16:28 +0100)
Runtime-tested on:
 - Linksprite pcDuino v2 (A10)
 - Olimex Olinuxino Micro (A20)
 - Bananapi M2 Berry (V40)
 - Bananapi P2 Zero (H2+)
 - OrangePi Zero2 (H616)

Patches refreshed where required.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch

index c6f98a0db44a5e9f6761a282a4c4146af40d6dad..e32718a5d33ae32d9f3d178417c0d301dd5bafdf 100644 (file)
@@ -9,9 +9,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
-PKG_VERSION:=2024.01
-
-PKG_HASH:=b99611f1ed237bf3541bdc8434b68c96a6e05967061f992443cb30aabebef5b3
+PKG_VERSION:=2025.01
+PKG_HASH:=cdef7d507c93f1bbd9f015ea9bc21fa074268481405501945abc6f854d5b686f
 
 PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
@@ -428,6 +427,11 @@ UBOOT_TARGETS := \
 
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
 
+UBOOT_CUSTOMIZE_CONFIG := \
+       --disable TOOLS_KWBIMAGE \
+       --disable TOOLS_LIBCRYPTO \
+       --disable TOOLS_MKEFICAPSULE
+
 UBOOT_MAKE_FLAGS += \
        BL31=$(STAGING_DIR_IMAGE)/bl31_sunxi-$(ATF).bin SCP=/dev/null
 
index 8605436b1ae873573f038967eb34ee345b3b936b..cef2835e45019dc95d746933587f25e67b85ca1b 100644 (file)
@@ -14,7 +14,7 @@ More specifically, the following settings are now used:
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
-@@ -131,11 +131,12 @@ void clock_set_pll1(unsigned int clk)
+@@ -128,11 +128,12 @@ void clock_set_pll1(unsigned int clk)
        struct sunxi_ccm_reg * const ccm =
                (struct sunxi_ccm_reg *)SUNXI_CCM_BASE;
        const int p = 0;
index b5fa2a14157fa616e8f50389dd5a70a5f0877f4b..64a3f25798f83b340e046ea877fc16561a98196f 100644 (file)
@@ -18,7 +18,7 @@ required setting for the PLL LDO is 1.37v as per the A31 manual.
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
-@@ -28,13 +28,26 @@ void clock_init_safe(void)
+@@ -27,13 +27,26 @@ void clock_init_safe(void)
        struct sunxi_prcm_reg * const prcm =
                (struct sunxi_prcm_reg *)SUNXI_PRCM_BASE;