multiwan: adjusted DNS rules to send out via correct interface.
authorCraig M. Coffee <cmcoffee@gmail.com>
Sat, 24 Apr 2010 17:54:48 +0000 (17:54 +0000)
committerCraig M. Coffee <cmcoffee@gmail.com>
Sat, 24 Apr 2010 17:54:48 +0000 (17:54 +0000)
SVN-Revision: 21144

net/multiwan/Makefile
net/multiwan/files/usr/bin/multiwan

index 628a6f03a75a63edc5d5f702da24c474e11aaa72..1bc7a9b66734f99b865cc0bf8b4df2537a3129bb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=multiwan
 PKG_VERSION:=1.0l
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index e0a67a86a41af87c6d982ef01063bf21d3cccf46..1d610f5962dd1da5df98aefcf74755b4ee8ddc25 100755 (executable)
@@ -475,7 +475,7 @@ dns=$(echo $dns | sed -e "s/ /\n/g")
 if [ ! -z "$dns" -a "$failchk" != "x" -a "$ipaddr" != "x" -a "$gateway" != "x" -a "$ifname" != "x" ]; then
 echo "$dns" | while read dns_server 
 do
-       iptables -t mangle -A MultiWanDNS -d $dns_server -p UDP --dport 53 -j FW${i}MARK
+       iptables -t mangle -A MultiWanDNS -d $dns_server -j FW${i}MARK
 
                compile_dns="nameserver $dns_server"
                echo "$compile_dns" >> $resolv_conf