projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ceffb97
)
Also build jffs2 images with 128k eraseblock size, signed off by Ithamar R. Adema
author
John Crispin
<john@openwrt.org>
Thu, 18 Mar 2010 11:20:35 +0000
(11:20 +0000)
committer
John Crispin
<john@openwrt.org>
Thu, 18 Mar 2010 11:20:35 +0000
(11:20 +0000)
SVN-Revision: 20267
target/linux/ifxmips/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ifxmips/image/Makefile
b/target/linux/ifxmips/image/Makefile
index 15e0bc5dc3978a0c71337da5116b25b03ed8c71d..ac887c4e49704c276529d3200d66df4757eb7847 100644
(file)
--- a/
target/linux/ifxmips/image/Makefile
+++ b/
target/linux/ifxmips/image/Makefile
@@
-27,6
+27,11
@@
define Image/Build/jffs2-64k
cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
endef
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/uImage of=$(KDIR)/uImage.$(1) bs=128k conv=sync
+ cat $(KDIR)/uImage.$(1) $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).image
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef