projects
/
openwrt
/
staging
/
noltari.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b19c48d
)
kernel: Add RIPEMD160 module
author
Rosen Penev
<rosenp@gmail.com>
Wed, 27 Mar 2019 20:39:49 +0000
(13:39 -0700)
committer
Christian Lamparter
<chunkeey@gmail.com>
Sat, 6 Apr 2019 17:14:06 +0000
(19:14 +0200)
After getting rid of cryptsetup's heavy openssl dependency, there is now
the problem of missing RIPEMD160 support. RIPEMD160 is used for True/Vera
crypt volumes as well as old LUKS1 ones.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index 1add16e161b2b1cd26dbd746f9af6f8f82a9cff8..fef9ea0ebff4dc1bd32ac028104680accc99f862 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-597,6
+597,18
@@
endef
$(eval $(call KernelPackage,crypto-rsa))
+define KernelPackage/crypto-rmd160
+ TITLE:=RIPEMD160 digest CryptoAPI module
+ DEPENDS:=+kmod-crypto-hash
+ KCONFIG:=CONFIG_CRYPTO_RMD160
+ FILES:=$(LINUX_DIR)/crypto/rmd160.ko
+ AUTOLOAD:=$(call AutoLoad,09,rmd160)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-rmd160))
+
+
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256