[packages] ddns-scripts: add ovh.com (#7340, thanks buggerone), dnsomatic.com (#8804...
authorStephen Walker <stephendwalker@gmail.com>
Wed, 25 Jan 2012 21:54:44 +0000 (21:54 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Wed, 25 Jan 2012 21:54:44 +0000 (21:54 +0000)
SVN-Revision: 29909

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/services

index 15eb0ec07ee2630eeab9aa89549c31be72c32ca4..03153e0a1dbf854c96ff2f3fa3c610528334b788 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=17
+PKG_RELEASE:=18
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 7c3439c62e880784d7f4cbed83a4554200620ccd..82461d270c374e4c978f3c84f39c79d0f4aff01b 100644 (file)
 
 # dnsExit.com free dynamic DNS update url
 "dnsexit.com"          "http://www.dnsexit.com/RemoteUpdate.sv?login=[USERNAME]&password=[PASSWORD]&host=[DOMAIN]&myip=[IP]"
+
+# OVH
+"ovh.com" "http://[USERNAME]:[PASSWORD]@www.ovh.com/nic/update?system=dyndns&hostname=[DOMAIN]&myip=[IP]"
+
+# dns-o-matic is a free service by opendns.com for updating multiple hosts and
+# dynamic dns services in one api call. To update all your configured services
+# at once, use "all.dnsomatic.com as the hostname.
+"dnsomatic.com" "http://[USERNAME]:[PASSWORD]@updates.dnsomatic.com/nic/update?hostname=[DOMAIN]&myip=[IP]"
+
+# 3322.org
+"3322.org"  "http://[USERNAME]:[PASSWORD]@members.3322.org/dyndns/update?system=dyndns&hostname=[DOMAIN]&myip=[IP]"
+
+# namecheap.com
+"namecheap.com" "http://dynamicdns.park-your-domain.com/update?host=[USERNAME]&domain=[DOMAIN]&password=[PASSWORD]&ip=[IP]"