mc: fixup broken symlinks to host automake (#6699)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 19 Feb 2010 03:06:29 +0000 (03:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 19 Feb 2010 03:06:29 +0000 (03:06 +0000)
SVN-Revision: 19727

utils/mc/Makefile

index a99ee63dd0ece26d1b45dbba76e63bd75cf37d57..93b8afc8cedd819a52259c715430e20a40a1b437 100644 (file)
@@ -63,6 +63,17 @@ CONFIGURE_ARGS += \
        --with-glib12 \
        --with-glib-prefix="$(STAGING_DIR)/usr" \
 
+
+AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
+
+define Build/Prepare
+       $(Build/Prepare/Default)
+       for script in config.guess config.sub depcomp install-sh missing; do \
+               rm -f $(PKG_BUILD_DIR)/config/$$$$script; \
+               ln -s $(AM_HOST)/$$$$script $(PKG_BUILD_DIR)/config/$$$$script; \
+       done
+endef
+
 define Package/mc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/