armsr: add realtek and smsc ethernet phy drivers to the default image
authorMathew McBride <matt@traverse.com.au>
Tue, 28 May 2024 23:09:17 +0000 (09:09 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Jul 2024 16:37:39 +0000 (18:37 +0200)
This adds two more common PHY brands to the image.
Realtek is used on the Google Coral "Phanbell" board (i.MX8MQ).
SMSC has been used on various Raspberry Pi boards.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
(cherry picked from commit bcbdde00c3a81a53d11ddc6101517185ae426691)
Link: https://github.com/openwrt/openwrt/pull/15808
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/armsr/image/Makefile

index 21f4c7dc547f6827b1fee85fa91a6883eead5890..4c20cf0e9f4293bf9cc8bc7a8f06a17e72e3a269 100644 (file)
@@ -112,7 +112,8 @@ define Device/generic
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
        kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
        kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic \
-       kmod-bcmgenet kmod-octeontx2-net kmod-renesas-net-avb
+       kmod-bcmgenet kmod-octeontx2-net kmod-renesas-net-avb \
+       kmod-phy-realtek kmod-phy-smsc
 endef
 TARGET_DEVICES += generic