projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
79e9e33
)
fix NO_TRACE_MAKE
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 22 Jul 2006 12:16:26 +0000
(12:16 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 22 Jul 2006 12:16:26 +0000
(12:16 +0000)
SVN-Revision: 4205
openwrt/include/verbose.mk
patch
|
blob
|
history
diff --git
a/openwrt/include/verbose.mk
b/openwrt/include/verbose.mk
index 7d9b3979bffcb171ff025375d4c1324a6ebca5ab..525fbf1c157178e6d4e2c4c39fa0a93222e31bba 100644
(file)
--- a/
openwrt/include/verbose.mk
+++ b/
openwrt/include/verbose.mk
@@
-6,13
+6,16
@@
#
# $Id:$
-export NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
ifndef KBUILD_VERBOSE
- KBUILD_VERBOSE=0
- ifeq ("$(origin V)", "command line")
-
KBUILD_VERBOSE=$(V
)
- endif
+ KBUILD_VERBOSE
:
=0
+endif
+
ifeq ("$(origin V)", "command line"
)
+ KBUILD_VERBOSE:=$(V)
endif
ifneq ($(KBUILD_VERBOSE),99)