#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-# $Id: $
+# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=pulseaudio
-PKG_VERSION:=0.9.9
+PKG_VERSION:=0.9.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/pulseaudio/
-PKG_MD5SUM:=8a6f7a9611bb194d94311764022b197
+PKG_MD5SUM:=9187ac1b302b9ab45f355242f453882e
+
+PKG_FIXUP = libtool
include $(INCLUDE_DIR)/package.mk
--with-access-group=root \
--without-x \
--enable-static-bins \
+ --enable-ltdl-install \
--disable-dbus \
--disable-hal \
--disable-gconf \
--disable-tcpwrap \
+
+CONFIGURE_VARS += \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
LIBOIL_CFLAGS="-I$(STAGING_DIR)/usr/include/liboil-0.3/" \
LIBOIL_LIBS="-L$(STAGING_DIR)/usr/lib/" \
-diff -urN pulseaudio-0.9.7/configure pulseaudio-0.9.7.new/configure
---- pulseaudio-0.9.7/configure 2007-10-30 17:02:51.000000000 +0100
-+++ pulseaudio-0.9.7.new/configure 2007-11-11 20:39:27.000000000 +0100
-@@ -29636,8 +29636,7 @@
+Index: pulseaudio-0.9.10/configure
+===================================================================
+--- pulseaudio-0.9.10.orig/configure 2008-04-11 13:28:12.000000000 +0200
++++ pulseaudio-0.9.10/configure 2008-04-11 13:28:12.000000000 +0200
+@@ -30281,8 +30281,7 @@
else
-
- { { echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
+
+ { { echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
-echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
- { (exit 1); exit 1; }; }
+echo "$as_me: error: *** libatomic-ops headers not found" >&2;} }
-
+
fi
-
-
+
-diff -urN pulseaudio-0.9.7/src/pulsecore/shm.c pulseaudio-0.9.7.new/src/pulsecore/shm.c
---- pulseaudio-0.9.7/src/pulsecore/shm.c 2007-10-28 20:13:53.000000000 +0100
-+++ pulseaudio-0.9.7.new/src/pulsecore/shm.c 2007-12-09 19:25:03.000000000 +0100
+Index: pulseaudio-0.9.10/src/pulsecore/shm.c
+===================================================================
+--- pulseaudio-0.9.10.orig/src/pulsecore/shm.c 2008-04-11 13:28:12.000000000 +0200
++++ pulseaudio-0.9.10/src/pulsecore/shm.c 2008-04-11 13:28:13.000000000 +0200
+@@ -125,7 +125,7 @@
+ m->do_unlink = 0;
+
+ } else {
+-#ifdef HAVE_SHM_OPEN
++#ifdef HAVE_SHM_UNLINK
+ struct shm_marker *marker;
+
+ pa_random(&m->id, sizeof(m->id));
@@ -167,7 +167,7 @@
fail:
if (munmap(m->ptr, m->size) < 0)
pa_log("munmap() failed: %s", pa_cstrerror(errno));
-@@ -370,8 +370,10 @@
+@@ -260,7 +260,7 @@
+ #endif
+ }
+
+-#ifdef HAVE_SHM_OPEN
++#ifdef HAVE_SHM_UNLINK
+
+ int pa_shm_attach_ro(pa_shm *m, unsigned id) {
+ char fn[32];
+@@ -318,7 +318,7 @@
+
+ int pa_shm_cleanup(void) {
+
+-#ifdef HAVE_SHM_OPEN
++#ifdef HAVE_SHM_UNLINK
+ #ifdef SHM_PATH
+ DIR *d;
+ struct dirent *de;
+@@ -371,8 +371,10 @@
/* Ok, the owner of this shms segment is dead, so, let's remove the segment */
segment_name(fn, sizeof(fn), id);
--- /dev/null
+Index: pulseaudio-0.9.10/src/daemon/caps.c
+===================================================================
+--- pulseaudio-0.9.10.orig/src/daemon/caps.c 2008-04-11 13:28:12.000000000 +0200
++++ pulseaudio-0.9.10/src/daemon/caps.c 2008-04-11 13:28:13.000000000 +0200
+@@ -131,9 +131,8 @@
+ return 0;
+ }
+
+-int pa_drop_caps(void) {
++void pa_drop_caps(void) {
+ pa_drop_root();
+- return 0;
+ }
+
+ #endif