kconfig: replace $(UNAME_RELEASE) with function call
authorMasahiro Yamada <yamada.masahiro@socionext.com>
Mon, 28 May 2018 09:21:47 +0000 (18:21 +0900)
committerMasahiro Yamada <yamada.masahiro@socionext.com>
Mon, 28 May 2018 18:31:19 +0000 (03:31 +0900)
Now that 'shell' function is supported, this can be self-contained in
Kconfig.

Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Reviewed-by: Kees Cook <keescook@chromium.org>
Reviewed-by: Ulf Magnusson <ulfalizer@gmail.com>
Makefile
init/Kconfig

index 59b86543da658e900ff00c07637ec1c3155ca6f9..58afa07bdf404b3d861ac53745a89276a38c2773 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -284,8 +284,7 @@ include scripts/Kbuild.include
 # Read KERNELRELEASE from include/config/kernel.release (if it exists)
 KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
 KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-UNAME_RELEASE := $(shell uname --release)
-export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION UNAME_RELEASE
+export VERSION PATCHLEVEL SUBLEVEL KERNELRELEASE KERNELVERSION
 
 # SUBARCH tells the usermode build what the underlying arch is.  That is set
 # first, and if a usermode build is happening, the "ARCH=um" on the command
index 1217fc62ca6193f1d12fdfb90525c7a33c31732d..f1b0cfb897628bc634e92c10f8a01cb58d2c2925 100644 (file)
@@ -2,9 +2,9 @@ config DEFCONFIG_LIST
        string
        depends on !UML
        option defconfig_list
-       default "/lib/modules/$(UNAME_RELEASE)/.config"
+       default "/lib/modules/$(shell,uname --release)/.config"
        default "/etc/kernel-config"
-       default "/boot/config-$(UNAME_RELEASE)"
+       default "/boot/config-$(shell,uname --release)"
        default ARCH_DEFCONFIG
        default "arch/$(ARCH)/defconfig"