sunxi: t113: add an extra step to copy u-boot into bin/ for eMMC boot support
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 26 Aug 2023 23:43:32 +0000 (01:43 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sun, 16 Feb 2025 21:20:53 +0000 (22:20 +0100)
Put an u-boot.bin into bin/ to make it easier for picking it to
install onto mmcblk1boot0.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
target/linux/sunxi/image/cortexa7.mk

index 283a7b973ce7d1c51c515c51a5203bdc78a10aa5..8acc19f5ba8726dfeb5e34e4f383e898ce50b378 100644 (file)
@@ -48,6 +48,10 @@ define Build/sunxi-emmc
        rm -f $@.boot
 endef
 
+define Build/sunxi-emmc-uboot-copy
+       $(CP) $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin $(BIN_DIR)/
+endef
+
 define Device/Default
   PROFILES := Default
   KERNEL_NAME := zImage
index 003ceaf64532874228e72d9c8e6ece2607781e3c..087826eb6489b1651676581006762bc0216407cc 100644 (file)
@@ -90,7 +90,7 @@ define Device/myir_myd-yt113x
   SOC := sun8i-t113s
   IMAGES += emmc.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
-  IMAGE/emmc.img.gz := boot-scr-emmc | sunxi-emmc | append-metadata | gzip
+  IMAGE/emmc.img.gz := sunxi-emmc-uboot-copy | boot-scr-emmc | sunxi-emmc | append-metadata | gzip
 endef
 TARGET_DEVICES += myir_myd-yt113x