[packages] bahamut: Don't use hosts zlib
authorLars-Peter Clausen <lars@metafoo.de>
Fri, 19 Feb 2010 04:11:47 +0000 (04:11 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Fri, 19 Feb 2010 04:11:47 +0000 (04:11 +0000)
SVN-Revision: 19729

net/bahamut/Makefile
net/bahamut/patches/010-dont-use-host-zlib.patch [new file with mode: 0644]

index 43954c92cd031856bae0be7b9b1edf4c487e8228..5092463c512afe2b170a8742276ba70ad3dadd0f 100644 (file)
@@ -34,6 +34,7 @@ define Build/Configure
                --with-openssl="$(STAGING_DIR)/usr/lib" \
                ,\
                ac_cv_func_dn_skipname=yes \
+               ZLIB_HOME="$(STAGING_DIR)/usr" \
        )
 endef
 
diff --git a/net/bahamut/patches/010-dont-use-host-zlib.patch b/net/bahamut/patches/010-dont-use-host-zlib.patch
new file mode 100644 (file)
index 0000000..ef8029c
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/configure b/configure
+index 4ef7659..c774c65 100755
+--- a/configure
++++ b/configure
+@@ -8009,11 +8009,6 @@ fi
+ # zlib test
+ # ripped from http://autoconf-archive.cryp.to/check_zlib.html
+ #
+-ZLIB_HOME=/usr/local
+-if test ! -f "${ZLIB_HOME}/include/zlib.h"
+-then
+-        ZLIB_HOME=/usr
+-fi
+ if test -n "${ZLIB_HOME}"
+ then
+         ZLIB_OLD_LDFLAGS=$LDFLAGS