projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
575d386
)
tools: xz: force building without ccache
author
Jo-Philipp Wich
<jo@mein.io>
Thu, 6 Oct 2016 13:25:12 +0000
(15:25 +0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Thu, 6 Oct 2016 13:29:33 +0000
(15:29 +0200)
Since XZ is required to bootstrap ccache we must not use the ccache compiler
wrapper to avoid circular dependencies.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/xz/Makefile
patch
|
blob
|
history
diff --git
a/tools/xz/Makefile
b/tools/xz/Makefile
index d08d6f899eb387f5be271767c1526cdadceb377f..45735e807fb926d675614043dbebcbd8fd6d6868 100644
(file)
--- a/
tools/xz/Makefile
+++ b/
tools/xz/Makefile
@@
-18,6
+18,9
@@
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
HOST_CONFIGURE_ARGS += \
--enable-static=yes \
--enable-shared=no \