build: fix filtering of non-upgradable packages
authorEric Fahlgren <ericfahlgren@gmail.com>
Thu, 21 Nov 2024 13:50:21 +0000 (05:50 -0800)
committerRobert Marko <robimarko@gmail.com>
Thu, 21 Nov 2024 16:55:45 +0000 (17:55 +0100)
Add anchor to name search so that we don't inadvertently filter out
packages containing, say, "kernel-" as part of their name.

Fixes: openwrt/packages#25372
Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/17032
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/Makefile

index 3c6621b81c3c13112bab39e2d9789cd616262142..ca43eb7e01642bd870c41152963de72c9122b44c 100644 (file)
@@ -131,7 +131,7 @@ ifneq ($(CONFIG_USE_APK),)
                        --keys-dir $(TOPDIR) \
                        --sign $(BUILD_KEY_APK_SEC) \
                        --output packages.adb \
-                       $$(ls *.apk | grep -v 'base-files-\|kernel-\|libc-'); \
+                       $$(ls *.apk | grep -vE '^(base-files-|kernel-|libc-)'); \
                echo -n '{"architecture": "$(ARCH_PACKAGES)", "packages":{' > index.json; \
                $(STAGING_DIR_HOST)/bin/apk adbdump packages.adb | \
                        awk '/- name: / {pkg = $$NF} ; / version: / {printf "\"%s\": \"%s\", ", pkg, $$NF}' | \