[packages_10.03.2] znc: merge r28774, r28775, r29724, r29875
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 20:45:54 +0000 (20:45 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 20:45:54 +0000 (20:45 +0000)
SVN-Revision: 30134

net/znc/Makefile
net/znc/files/znc.init
net/znc/patches/001-move_rootcheck_after_config.patch
net/znc/patches/002-Uclibcpp_build_fix.patch
net/znc/patches/003-Reduce_rebuild_time.patch
net/znc/patches/004-fix_memleak.patch [deleted file]

index e6488db2a8f8574df5e45c9b039dba0c9070762b..2ad7511f74e4731845972338993127553e269a00 100644 (file)
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
-PKG_VERSION:=0.098
-PKG_RELEASE:=4
+PKG_VERSION:=0.204
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://znc.in/releases
-PKG_MD5SUM:=5667b4acb1f01309d6eded77abac700c
+PKG_SOURCE_URL:=http://znc.in/releases \
+               http://znc.in/releases/archive
+PKG_MD5SUM:=7c7247423fc08b0c5c62759a50a9bca3
 
 PKG_BUILD_PARALLEL:=1
 
@@ -74,9 +75,9 @@ define module
        $(INSTALL_DIR) $$(1)/usr/lib/znc/
        $(INSTALL_BIN) $$(PKG_BUILD_DIR)/modules/$(strip $(3))$(subst -,_,$(strip $(1))).so $$(1)/usr/lib/znc/
        # include webadmin page templates if existing
-       if [ -d $$(PKG_BUILD_DIR)/modules/$(strip $(3))$(subst -,_,$(strip $(1))) ]; then \
-               $(INSTALL_DIR) $$(1)/usr/share/znc/ ;\
-               $(CP) -r $$(PKG_BUILD_DIR)/modules/$(strip $(3))$(subst -,_,$(strip $(1))) $$(1)/usr/share/znc/ ;\
+       if [ -d $$(PKG_BUILD_DIR)/modules/$(strip $(3))data/$(subst -,_,$(strip $(1))) ]; then \
+               $(INSTALL_DIR) $$(1)/usr/share/znc/modules ;\
+               $(CP) -r $$(PKG_BUILD_DIR)/modules/$(strip $(3))data/$(subst -,_,$(strip $(1))) $$(1)/usr/share/znc/modules ;\
        fi
   endef
 
@@ -98,8 +99,8 @@ define webadmin
   define Package/znc-mod-webadmin/install
        $(INSTALL_DIR) $$(1)/usr/lib/znc/
        $(INSTALL_BIN) $$(PKG_BUILD_DIR)/modules/webadmin.so $$(1)/usr/lib/znc/
-       $(INSTALL_DIR) $$(1)/usr/share/znc/
-       $(CP) -r $$(PKG_BUILD_DIR)/modules/webadmin $$(1)/usr/share/znc/
+       $(INSTALL_DIR) $$(1)/usr/share/znc/modules
+       $(CP) -r $$(PKG_BUILD_DIR)/modules/data/webadmin $$(1)/usr/share/znc/modules
        $(INSTALL_DIR) $$(1)/usr/share/znc/webskins/
        $(CP) -r $$(PKG_BUILD_DIR)/webskins/_default_ $$(1)/usr/share/znc/webskins/
   endef
@@ -136,26 +137,26 @@ $(eval $(call module,adminlog,Log user connects and disconnects and failed \
 
 $(eval $(call module,autoattach,Reattaches you to channels on activity.))
 
-$(eval $(call module,autocycle,Cycles a channel when you are the only one in \
-       there and you don't have op.))
-
 $(eval $(call module,autoop,Auto op the good guys.))
 
 $(eval $(call module,autoreply,Gives a automatic reply if someone messages you \
        if you are away.))
 
-$(eval $(call module,away,Stores messages while away$(,) also auto away.))
-
 $(eval $(call module,awaynick,Change your nick while you are away.))
 
 $(eval $(call module,blockuser,Blocks certain users from using ZNC saying \
        their account was disabled.))
 
+$(eval $(call module,bouncedcc,Bounces dcc transfers through the znc server \
+       instead of sending them directly to the user.))
+
 $(eval $(call module,buffextras,Add nick changes$(,) joins$(,) parts$(,) topic \
        changes etc. to your playback buffer.))
 
-$(eval $(call module,certauth,This module allows users to log in via SSL \
-       client keys.))
+$(eval $(call module,cert,Use a SSL certificate for connecting to a server.))
+
+$(eval $(call module,certauth,This module allows users to log in to ZNC via \
+       SSL client keys.))
 
 $(eval $(call module,chansaver,Keeping config up to date when user joins and \
        parts.))
@@ -170,6 +171,9 @@ $(eval $(call module,disconkick,This module will kick your client from all \
 
 $(eval $(call module,fail2ban,Block IPs for some time after a failed login.))
 
+$(eval $(call module,identfile,Places the ident of a user to a file when they \
+        are trying to connect.))
+
 $(eval $(call module,keepnick,Tries to get you your primary nick.))
 
 $(eval $(call module,kickrejoin,Implements auto-rejoin-on-kick.))
@@ -208,9 +212,14 @@ $(eval $(call module,watch,Monitor activity for specific text patterns from \
 
 $(eval $(call module,antiidle,Hides your idle time.,extra/))
 
+$(eval $(call module,autocycle,Cycles a channel when you are the only one in \
+       there and you don't have op.,extra/))
+
 $(eval $(call module,autovoice,Autovoices everyone who joins some channel., \
        extra/))
 
+$(eval $(call module,away,Stores messages while away$(,) also auto away.,extra/))
+
 $(eval $(call module,block-motd,This module blocks the server's Message of the \
        Day.,extra/))
 
@@ -219,6 +228,10 @@ $(eval $(call module,clearbufferonmsg,This module keeps the buffer until the \
 
 $(eval $(call module,ctcpflood,This module tries to block ctcp floods.,extra/))
 
+$(eval $(call module,dcc,Allows you to transfer files to and from ZNC.,extra/))
+
+$(eval $(call module,email,Watches a local mailbox for new mails.,extra/))
+
 $(eval $(call module,fakeonline,This module fakes the online status of \
        ZNC-*users.,extra/))
 
index be2f3f5a75e9b0faac459db29b67c178cb30bb54..01af217a9e7a317c7221b18c349532d59360f2ed 100644 (file)
@@ -52,7 +52,7 @@ znc_global() {
                config_get serverthrottle "$znc" serverthrottle
                config_get znc_pem_file "$znc" znc_ssl_cert
 
-               [ -z $znc_pem_file -o -f $ZNC_CONFIG_PATH/znc.pem ] || ln -s "$znc_pem_file" $ZNC_CONFIG_PATH/znc.pem
+               [ -z "$znc_pem_file" ] || ln -sf "$znc_pem_file" $ZNC_CONFIG_PATH/znc.pem
 
                [ -z $anoniplimit ] || echo "AnonIPLimit = $anoniplimit" >> $ZNC_CONFIG
                [ -z $maxbuffersize ] || echo "MaxBufferSize = $maxbuffersize" >> $ZNC_CONFIG
@@ -127,7 +127,7 @@ start() {
                config_foreach add_listener listener
                config_foreach add_user user
 
-               chown -R ${RUNAS_USER:-nobody}:${RUNAS_GROUP:-nogroup} /tmp/etc/znc
+               chown -hR ${RUNAS_USER:-nobody}:${RUNAS_GROUP:-nogroup} /tmp/etc/znc
        fi
 
        if [ "$EXTERNAL_CONFIG" -eq 1 -a "$RUNAS_USER"  ]
index b64f247d2b41347a345b992ea926beb94713ee58..96ba8e3bb115fb1d47463738557317d91182bcf7 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] Move the root check to after config parsing
 
 --- a/main.cpp
 +++ b/main.cpp
-@@ -194,19 +194,6 @@ int main(int argc, char** argv) {
+@@ -211,19 +211,6 @@ int main(int argc, char** argv) {
        }
  #endif
  
@@ -29,7 +29,7 @@ Subject: [PATCH] Move the root check to after config parsing
        if (bMakeConf) {
                if (!pZNC->WriteNewConfig(sConfig)) {
                        delete pZNC;
-@@ -227,6 +214,20 @@ int main(int argc, char** argv) {
+@@ -244,6 +231,20 @@ int main(int argc, char** argv) {
                return 1;
        }
  
index 505f03d28ab7e3241566104fb170eeebb7970600..1c484789c8ac2ca0d7527bbfe33beb2f581d40f7 100644 (file)
@@ -23,7 +23,7 @@ Subject: [PATCH] Add a uClibc++ build workaround
  
  /* Stuff to be able to write this:
     // i will be name of local variable, see below
-@@ -58,7 +60,7 @@ class CWebAdminMod : public CGlobalModul
+@@ -55,7 +57,7 @@ class CWebAdminMod : public CGlobalModul
  public:
        GLOBALMODCONSTRUCTOR(CWebAdminMod) {
                VPair vParams;
index 0f48c65f37976b1f5b4c997af3875963e766bf15..5c6fcd916dea5a187d0dbbf11da6430f10cd226d 100644 (file)
@@ -21,7 +21,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
        $(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MMD -MF .depend/$@.dep
 --- a/modules/Makefile.in
 +++ b/modules/Makefile.in
-@@ -114,7 +114,7 @@ install_metadirs: create_install_dir
+@@ -114,7 +114,7 @@ install_datadir:
  clean:
        rm -rf $(CLEAN)
  
diff --git a/net/znc/patches/004-fix_memleak.patch b/net/znc/patches/004-fix_memleak.patch
deleted file mode 100644 (file)
index 51394c0..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Chan.cpp
-+++ b/Chan.cpp
-@@ -417,9 +417,10 @@ bool CChan::AddNick(const CString& sNick
-       // Get the nick
-       sTmp   = sTmp.Token(0, false, "!");
-+      CNick tmpNick(sTmp);
-       CNick* pNick = FindNick(sTmp);
-       if (!pNick) {
--              pNick = new CNick(sTmp);
-+              pNick = &tmpNick;
-               pNick->SetUser(m_pUser);
-       }