projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d973768
)
fix libsas and mvsas dependencies against PCI and not x86
author
Florian Fainelli
<florian@openwrt.org>
Wed, 25 Jul 2012 15:49:46 +0000
(15:49 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Wed, 25 Jul 2012 15:49:46 +0000
(15:49 +0000)
SVN-Revision: 32847
package/kernel/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/block.mk
b/package/kernel/modules/block.mk
index cdf3effc5aef3a5209d7c060be58729ff40d9d3b..819b748b5316a18c7851a2a8ce5987de0e21a38f 100644
(file)
--- a/
package/kernel/modules/block.mk
+++ b/
package/kernel/modules/block.mk
@@
-492,7
+492,6
@@
$(eval $(call KernelPackage,ide-it821x))
define KernelPackage/libsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=SAS Domain Transport Attributes
- DEPENDS:=@TARGET_x86
KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
CONFIG_SCSI_SAS_ATTRS \
CONFIG_SCSI_SAS_ATA=y \
@@
-531,7
+530,7
@@
$(eval $(call KernelPackage,loop))
define KernelPackage/mvsas
SUBMENU:=$(BLOCK_MENU)
TITLE:=Marvell 88SE6440 SAS/SATA driver
- DEPENDS:=@
TARGET_x86
+kmod-libsas
+ DEPENDS:=@
PCI_SUPPORT
+kmod-libsas
KCONFIG:= \
CONFIG_SCSI_MVSAS \
CONFIG_SCSI_MVSAS_TASKLET=n