projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a15b4bf
)
allow files/ to overwrite existing symlinks (fixes #3508)
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 23 Jan 2011 20:59:13 +0000
(20:59 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 23 Jan 2011 20:59:13 +0000
(20:59 +0000)
SVN-Revision: 25078
package/Makefile
patch
|
blob
|
history
diff --git
a/package/Makefile
b/package/Makefile
index 786edd49f00955ea114e80caad8347847a9b0f31..8e8c6c9a63fecbc4d4dea74cdec1b96bf4b7cf4d 100644
(file)
--- a/
package/Makefile
+++ b/
package/Makefile
@@
-64,6
+64,14
@@
endif
$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
@-$(MAKE) package/preconfig
@if [ -d $(TOPDIR)/files ]; then \
+ ( cd $(TOPDIR)/files; find -type f ) | \
+ ( cd $(TARGET_DIR); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; ); \
$(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
fi
@mkdir -p $(TARGET_DIR)/etc/rc.d